Only new-run-webkit-tests uses python 2.7 on the leopard bots.  There are other bot steps in chromium that would break.  I mention a couple cases here:<div><a href="http://code.google.com/p/chromium/issues/detail?id=103266#c6">http://code.google.com/p/chromium/issues/detail?id=103266#c6</a></div>
<div><br></div><div>Alternately, we could try to fully switch the leopard bots to 2.7 (<a href="http://crbug.com/103828">http://crbug.com/103828</a>), but that's a larger task.<br><br><div class="gmail_quote">On Thu, Nov 17, 2011 at 3:19 PM, Dirk Pranke <span dir="ltr"><<a href="mailto:dpranke@chromium.org">dpranke@chromium.org</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="im">On Thu, Nov 17, 2011 at 2:45 PM, Adam Barth <<a href="mailto:abarth@webkit.org">abarth@webkit.org</a>> wrote:<br>

> On Thu, Nov 17, 2011 at 2:42 PM, Dirk Pranke <<a href="mailto:dpranke@chromium.org">dpranke@chromium.org</a>> wrote:<br>
>> The Chromium Leopard bots are still using 2.5 as far as I know. Unless<br>
>> "move forward" includes you upgrading those bots, you shouldn't remove<br>
>> the 2.5 compat code until they have been upgraded. (If you are signing<br>
>> up to upgrade them, then great!).<br>
><br>
> Tony already upgraded the bots.<br>
><br>
> Adam<br>
><br>
<br>
</div>I have been corrected. You have my blessings :).<br>
<div class="HOEnZb"><div class="h5">_______________________________________________<br>
webkit-dev mailing list<br>
<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
<a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
</div></div></blockquote></div><br></div>