Are you sure?  This output has references to System/Library/Frameworks/Python.framework/Versions/2.5.  I also thought that's why NRWT was slow on the Leopard bots: python 2.5 doesn't have the multiprocess module.<div>
<br></div><div><a href="http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Mac10.5%20%28dbg%29%281%29/builds/4090/steps/webkit_tests/logs/stdio">http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Mac10.5%20%28dbg%29%281%29/builds/4090/steps/webkit_tests/logs/stdio</a><br>
<br>It may just be a bug that these bots aren't using python2.6.<br><br><div class="gmail_quote">On Fri, Nov 4, 2011 at 3:40 PM, Adam Barth <span dir="ltr"><<a href="mailto:abarth@webkit.org">abarth@webkit.org</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Yes, Chromium versions its Python independently from the OS.<br>
<span class="HOEnZb"><font color="#888888"><br>
Adam<br>
</font></span><div class="HOEnZb"><div class="h5"><br>
<br>
On Fri, Nov 4, 2011 at 3:25 PM, Ojan Vafai <<a href="mailto:ojan@chromium.org">ojan@chromium.org</a>> wrote:<br>
> I believe the chromium port always uses 2.6 though, no?<br>
><br>
> On Fri, Nov 4, 2011 at 3:23 PM, Nico Weber <<a href="mailto:thakis@chromium.org">thakis@chromium.org</a>> wrote:<br>
>><br>
>> The chromium port still has a bot that runs tests (but doesn't build) on<br>
>> 10.5.<br>
>><br>
>> Nico<br>
>><br>
>> On Fri, Nov 4, 2011 at 3:20 PM, Eric Seidel <<a href="mailto:eric@webkit.org">eric@webkit.org</a>> wrote:<br>
>> > Now that Apple has removed the Leopard build bot (and presumably<br>
>> > stopped supporting WebKit on Leopard), all webkit platforms I know of<br>
>> > have Python 2.6 or higher.<br>
>> ><br>
>> > My plan is to remove all of our 2.5 supporting code in the next week,<br>
>> > requiring Python 2.6 or later for WebKit.<br>
>> ><br>
>> > Let me know if this will be an issue for you.<br>
>> ><br>
>> > Thanks!<br>
>> ><br>
>> > -eric<br>
>> > _______________________________________________<br>
>> > webkit-dev mailing list<br>
>> > <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
>> > <a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
>> ><br>
>> _______________________________________________<br>
>> webkit-dev mailing list<br>
>> <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
>> <a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
><br>
><br>
> _______________________________________________<br>
> webkit-dev mailing list<br>
> <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
> <a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
><br>
><br>
_______________________________________________<br>
webkit-dev mailing list<br>
<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
<a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
</div></div></blockquote></div><br></div>