<br><br><div class="gmail_quote">On Mon, Aug 22, 2011 at 3:24 PM, Adam Barth <span dir="ltr"><<a href="mailto:abarth@webkit.org">abarth@webkit.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div><div></div><div class="h5">On Mon, Aug 22, 2011 at 3:18 PM, James Robinson <<a href="mailto:jamesr@google.com">jamesr@google.com</a>> wrote:<br>
> On Mon, Aug 22, 2011 at 3:07 PM, Adam Barth <<a href="mailto:abarth@webkit.org">abarth@webkit.org</a>> wrote:<br>
>> On Mon, Aug 22, 2011 at 3:02 PM, James Robinson <<a href="mailto:jamesr@google.com">jamesr@google.com</a>> wrote:<br>
>> > On Mon, Aug 22, 2011 at 2:55 PM, Adam Barth <<a href="mailto:abarth@webkit.org">abarth@webkit.org</a>> wrote:<br>
>> >> I've been trying to wrap my mind around the "GPU" LayoutTests that<br>
>> >> Chromium runs.  In<br>
>> >> <<a href="http://trac.webkit.org/browser/trunk/LayoutTests/platform" target="_blank">http://trac.webkit.org/browser/trunk/LayoutTests/platform</a>>, there are<br>
>> >> the following directories:<br>
>> >><br>
>> >> chromium-gpu<br>
>> >> chromium-gpu-cg-mac<br>
>> >> chromium-gpu-linux<br>
>> >> chromium-gpu-win<br>
>> >><br>
>> >> These seem to be related to the webkit_gpu_tests step on these bots:<br>
>> >><br>
>> >><br>
>> >> <a href="http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Mac10.5%20%28CG%29" target="_blank">http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Mac10.5%20%28CG%29</a><br>
>> >><br>
>> >><br>
>> >> <a href="http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Mac10.6%20%28CG%29" target="_blank">http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Mac10.6%20%28CG%29</a><br>
>> >> <a href="http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Linux" target="_blank">http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Linux</a><br>
>> >> <a href="http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Vista" target="_blank">http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Vista</a><br>
>> >> <a href="http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Win7" target="_blank">http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Win7</a><br>
>> >><br>
>> >> This file<br>
>> >><br>
>> >> <<a href="http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/layout_tests/port/builders.py" target="_blank">http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/layout_tests/port/builders.py</a>><br>

>> >> also lists the following bots:<br>
>> >><br>
>> >> Webkit Win - GPU<br>
>> >> Webkit Win7 - GPU<br>
>> >> Webkit Linux - GPU<br>
>> >> Webkit Linux 32 - GPU<br>
>> >> Webkit Mac10.5 (CG) - GPU<br>
>> >> Webkit Mac10.6 (CG) - GPU<br>
>> >><br>
>> >> Questions:<br>
>> >><br>
>> >> 1) Do these "- GPU" bots exist anywhere?  (I can't find them, and a<br>
>> >> recent bug comment indicates that they might be fictional.)<br>
>> ><br>
>> > The " - GPU" bots are the same bots as the normal layout test bots, but<br>
>> > run<br>
>> > as a separate step.<br>
>> ><br>
>> >  See <a href="http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Mac10.6%20%28CG%29/builds/185" target="_blank">http://build.chromium.org/p/chromium.webkit/builders/Webkit%20Mac10.6%20%28CG%29/builds/185</a>,<br>

>> > for example.  The "bot name" for the GPU tests is the normal bot name<br>
>> > with "<br>
>> > - GPU" appended.<br>
>> ><br>
>> >><br>
>> >> 2) Are there any other bots related to the GPU configuration other<br>
>> >> than those listed above?  (For example, is there any coverage of this<br>
>> >> configuration on <a href="http://build.webkit.org" target="_blank">build.webkit.org</a>?)<br>
>> ><br>
>> > <a href="http://build.webkit.org" target="_blank">build.webkit.org</a> seems to not be running these tests, for reasons that<br>
>> > are<br>
>> > unclear to me, but they run on the other chromium bots that run layout<br>
>> > tests.<br>
>> ><br>
>> >> 3) Why is webkit_gpu_tests a separate step from webkit_tests?<br>
>> ><br>
>> > Different flags are passed to DumpRenderTree, but it runs some of the<br>
>> > same<br>
>> > tests.  This is so we can get coverage for (for instance) the 2d canvas<br>
>> > API<br>
>> > in our hardware and software paths.<br>
>><br>
>> Could we instead use the layoutTestController to enable or disable<br>
>> whatever flags at test-time rather than on the command line?  For<br>
>> example, we could put the guts of the 2d canvas tests into a<br>
>> JavaScript file and include it in two HTML files, one that sets the<br>
>> flag and one that does not.  That's how we handle strict vs quirks<br>
>> mode, for example.<br>
><br>
> There are 802 tests in canvas/philip/tests/ (which is an imported suite),<br>
> currently all implemented as separate .html files, and another 166 in<br>
> fast/canvas.  It seems a bit tedious to manually wrap each of these tests in<br>
> two different wrappers.  That doesn't seem like a very practical option,<br>
> although it has some nice aspects.<br>
<br>
</div></div>I'd be happy to edit these thousand files if it meant we could remove<br>
the complexity of the GPU configuration.</blockquote><div><br></div><div>You would have to modify all currently existing tests, and all such tests that will be added in the future.  I'm not sure how to patch tests that will only exist in the future.</div>
<div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">  The ongoing maintenance cost<br>
of the GPU configuration strikes me as a lot greater than the one-time<br>
cost of changing these tests.  (There's also the side-benefit of<br>
letting all the other ports increase their test coverage by wiring up<br>
the LayoutTestController method.)<br>
<br>
I suspect (although I'd have to look more carefully), that we could<br>
make this work for the canvas/philip/tests tests without actually<br>
modifying the files (e.g., using iframes), if we wanted the ability to<br>
easily import new versions of that test suite.<br></blockquote><div><br></div><div>That would seem to imply either running all of the relevant twice for all ports, unless this iframe solution was chromium-specific.  Would that really be simpler?</div>
<div><br></div><div>What concrete costs are you attempting to minimize?  It is difficult to modify our tools due to this configuration, but the complexity is restricted nearly fully to chromium-specific scripts.  The tests themselves and other ports are unaffected.</div>
<div><br></div><div>- James</div><div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<font color="#888888"><br>
Adam<br>
</font><div><div></div><div class="h5"><br>
<br>
>> >> As far as I can tell, other ports, such as Apple-Mac, make use of the<br>
>> >> GPU but don't impose as large a complexity tax on the project.  Is<br>
>> >> there something different about Chromium's GPU support that requires<br>
>> >> this additional complexity?<br>
>> ><br>
>> > Other ports have less test coverage, and they don't run the pixel tests<br>
>> > at<br>
>> > all on the bots.<br>
>><br>
>> Adam<br>
><br>
><br>
</div></div></blockquote></div><br>