<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div><div>On Jun 20, 2011, at 11:21 PM, Brian Stuart wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div>Thanks for your reply, </div><div>Yes I need to build an older version of webkit that was forked and has some custom changes. </div><div><br></div><div>Any idea where I might find the correct version of WebkitSupportLibrary.zip?</div></div></blockquote><div><br></div>Old versions of WebKitSupportLibrary.zip aren't made available anywhere. (And even if you did have an old WebKitSupportLibrary.zip lying around, you'd also need the matching old version of Safari in order for the WebKit you built with it to actually be usable.)</div><div><br></div><div>You could try using the latest version of update-webkit-support-libs and WebKitSupportLibrary.zip. Hopefully it will work with your old version of WebKit without requiring too many changes.</div><div><br></div><div>-Adam</div><div><br><blockquote type="cite"><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div><div>On Jun 20, 2011, at 8:00 PM, Adam Roben wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div><div>On Jun 1, 2011, at 8:38 PM, Brian Stuart wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div style="margin-top: 0in; margin-right: 0in; margin-bottom: 0.0001pt; margin-left: 0in; font-size: 11pt; font-family: Calibri, sans-serif; ">Hi All,<o:p></o:p></div><div style="margin-top: 0in; margin-right: 0in; margin-bottom: 0.0001pt; margin-left: 0in; font-size: 11pt; font-family: Calibri, sans-serif; ">I am trying to build a fork of WebKit on windows that requires a version of WebKitSupportLibrary.zip different than the one currently available from <a href="http://developer.apple.com/opensource/internet/webkit_sptlib_agree.html" style="color: blue; text-decoration: underline; ">http://developer.apple.com/opensource/internet/webkit_sptlib_agree.html</a><o:p></o:p></div><div style="margin-top: 0in; margin-right: 0in; margin-bottom: 0.0001pt; margin-left: 0in; font-size: 11pt; font-family: Calibri, sans-serif; "><o:p> </o:p></div><div style="margin-top: 0in; margin-right: 0in; margin-bottom: 0.0001pt; margin-left: 0in; font-size: 11pt; font-family: Calibri, sans-serif; ">In the script “WebKitTools/Scripts/update-webkit-support-libs” it’s looking for a version of WebKitSupportLibrary.zip with a checksum of "a1341aadbcce1ef26dad2b2895457314"<o:p></o:p></div><div style="margin-top: 0in; margin-right: 0in; margin-bottom: 0.0001pt; margin-left: 0in; font-size: 11pt; font-family: Calibri, sans-serif; "><o:p> </o:p></div><div style="margin-top: 0in; margin-right: 0in; margin-bottom: 0.0001pt; margin-left: 0in; font-size: 11pt; font-family: Calibri, sans-serif; ">Does anyone know where I can download the correct version of WebKitSupportLibrary.zip?</div></div></div></blockquote></div><br><div>Are you trying to build an old version of WebKit? update-webkit-support-libs no longer uses a checksum to verify the version of the zip file.</div><div><br></div><div>-Adam</div><div><br></div></div></blockquote></div><br></div></blockquote></div><br></body></html>