Actually, looks like this is a WebKit2-related bug. It just happens that this is the only non-pixel test that depends on the window having focus. For example, the following fails on my SnowLeopard machine due to lacking the focus ring:<div>

<div>run-webkit-tests --debug -2 fast/css/focus-ring-outline-color.html -p --tolerance 0</div><div><br></div><br><div class="gmail_quote">On Wed, Mar 23, 2011 at 4:13 PM, Stephanie Lewis <span dir="ltr"><<a href="mailto:slewis@apple.com">slewis@apple.com</a>></span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">The machine did have a software update dialog up.  However, i dismissed the dialog and the test is still failing.<br>

<br>
-- Stephanie<br>
<div class="im"><br>
On Mar 22, 2011, at 9:29 PM, Ojan Vafai wrote:<br>
<br>
> fast/css/pseudo-any.html is failing on SnowLeopard Intel Release (WebKit2 Tests), but it's not failing on SnowLeopard Intel Release (Tests). The test depends on the window having focus and the failure it's getting is the one you get if you load the page in a blurred window. So, I assume some dialog or something is up on that bot causing focus issues. What I don't get is that there are other tests that depend on the window having focus that don't seem to be failing on this bot. Does someone with access to the bot mind taking a look?<br>


><br>
> Ojan<br>
</div>> _______________________________________________<br>
> webkit-dev mailing list<br>
> <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
> <a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
<br>
</blockquote></div><br></div>