Thanks a lot. It solve my problem.<br><br>Regards,<br>Diego<br><br><div class="gmail_quote">On Tue, Aug 31, 2010 at 6:24 PM, Chris Hatko <span dir="ltr">&lt;<a href="mailto:chatko@gmail.com">chatko@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">I presume this is a release build ... I ran into this problem myself.<br>
You can switch to 64Bit OS or turn off &quot;whole program optimization&quot;<br>
/GL and corresponding linker flag.<br>
<br>
Chris<br>
<br>
On Tue, Aug 31, 2010 at 5:20 PM, Diego Gonzalez<br>
<div><div></div><div class="h5">&lt;<a href="mailto:diego.gonzalez@openbossa.org">diego.gonzalez@openbossa.org</a>&gt; wrote:<br>
&gt; Hi,<br>
&gt;<br>
&gt; Thanks for the feedback!<br>
&gt;<br>
&gt; On Tue, Aug 31, 2010 at 12:01 PM, Ilya Tikhonovsky &lt;<a href="mailto:loislo@chromium.org">loislo@chromium.org</a>&gt;<br>
&gt; wrote:<br>
&gt;&gt;<br>
&gt;&gt; It is the problem with VC project properties.<br>
&gt;&gt; The build script just remove all the properties<br>
&gt;&gt; from WebKitLibraries/win/tools/vsprops/ by mistake.<br>
&gt;&gt; This problem happens if you use git.<br>
&gt;&gt; I&#39;ve created a bug about<br>
&gt;&gt; that. <a href="https://bugs.webkit.org/show_bug.cgi?id=44050" target="_blank">https://bugs.webkit.org/show_bug.cgi?id=44050</a><br>
&gt;&gt; The dirty hack for this is just create .svn file<br>
&gt;&gt; in WebKitLibraries/win/tools/vsprops/ folder and restore the files from the<br>
&gt;&gt; repository.<br>
&gt;<br>
&gt; My problem was related to git and your trick solve my build failures. Thanks<br>
&gt; a lot<br>
&gt;<br>
&gt; My problem now is to link the WebKit lib:<br>
&gt;<br>
&gt; 11&gt;Compiling resources...<br>
&gt; 11&gt;Performing Pre-Link Event...<br>
&gt; 11&gt;        1 file(s) copied.<br>
&gt; 11&gt;        1 file(s) copied.<br>
&gt; 11&gt;Linking...<br>
&gt; 11&gt;fatal error C1083: Cannot open compiler intermediate file:<br>
&gt; &#39;C:\cygwin\home\rodribel\webkit\WebKitBuild\lib\WebKitLib.lib&#39;: Not enough<br>
&gt; space<br>
&gt; 11&gt;LINK : fatal error LNK1257: code generation failed<br>
&gt;<br>
&gt; Do you (or anyone) knows about why this linking is exceeding the space?<br>
&gt;<br>
&gt;<br>
&gt; Regards,<br>
&gt; Diego<br>
&gt;<br>
&gt;&gt;<br>
&gt;&gt; Regards,<br>
&gt;&gt; Tim.<br>
&gt;&gt;<br>
&gt;&gt;<br>
&gt;&gt; On Tue, Aug 31, 2010 at 6:16 PM, Diego Gonzalez<br>
&gt;&gt; &lt;<a href="mailto:diego.gonzalez@openbossa.org">diego.gonzalez@openbossa.org</a>&gt; wrote:<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; Hi folks,<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; I have some problems to build WebKit ToT on my Window Env.<br>
&gt;&gt;&gt; I&#39;m using Visual C++ express 2005.<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; I&#39;ve followed the steps win: <a href="http://webkit.org/building/tools.html" target="_blank">http://webkit.org/building/tools.html</a><br>
&gt;&gt;&gt; After it I ran update-webkit and build-wekit script<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; I got this build output: <a href="http://pastebin.com/x99zta73" target="_blank">http://pastebin.com/x99zta73</a><br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; Some  build errors like:<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; InspectorStorageAgent.cpp<br>
&gt;&gt;&gt; ..\inspector\InspectorStorageAgent.cpp(64) : error C2039:<br>
&gt;&gt;&gt; &#39;sqlTransactionFailed&#39; : is not a member of &#39;WebCore::InspectorFrontend&#39;<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; C:\cygwin\home\rodribel\webkit\WebKitBuild\obj\WebCore\DerivedSources\InspectorFrontend.h(17)<br>
&gt;&gt;&gt; : see declaration of &#39;WebCore::InspectorFrontend&#39;<br>
&gt;&gt;&gt; ..\inspector\InspectorStorageAgent.cpp(98) : error C2039:<br>
&gt;&gt;&gt; &#39;sqlTransactionSucceeded&#39; : is not a member of &#39;WebCore::InspectorFrontend&#39;<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; C:\cygwin\home\rodribel\webkit\WebKitBuild\obj\WebCore\DerivedSources\InspectorFrontend.h(17)<br>
&gt;&gt;&gt; : see declaration of &#39;WebCore::InspectorFrontend&#39;<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; and<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; SVGCSSStyleSelector.cpp<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2217)<br>
&gt;&gt;&gt; : error C2065: &#39;CSSValueButt&#39; : undeclared identifier<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2231)<br>
&gt;&gt;&gt; : error C2051: case expression not constant<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2249)<br>
&gt;&gt;&gt; : error C2065: &#39;CSSValueMiter&#39; : undeclared identifier<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2255)<br>
&gt;&gt;&gt; : error C2065: &#39;CSSValueBevel&#39; : undeclared identifier<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2263)<br>
&gt;&gt;&gt; : error C2051: case expression not constant<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2267)<br>
&gt;&gt;&gt; : error C2051: case expression not constant<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2281)<br>
&gt;&gt;&gt; : error C2065: &#39;CSSValueNonzero&#39; : undeclared identifier<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2284)<br>
&gt;&gt;&gt; : error C2065: &#39;CSSValueEvenodd&#39; : undeclared identifier<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; seems to be related with features disabled (e.g. database, svg) but these<br>
&gt;&gt;&gt; featrues were not disabled for the build. As I do not have experience<br>
&gt;&gt;&gt; with these Windows build tools, I wonder if someone could give me some<br>
&gt;&gt;&gt; directions to get this build ok.<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; Thanks,<br>
&gt;&gt;&gt; Diego<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; _______________________________________________<br>
&gt;&gt;&gt; webkit-dev mailing list<br>
&gt;&gt;&gt; <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt;&gt;&gt; <a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
&gt;&gt;&gt;<br>
&gt;&gt;<br>
&gt;<br>
&gt;<br>
&gt; _______________________________________________<br>
&gt; webkit-dev mailing list<br>
&gt; <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt; <a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
&gt;<br>
&gt;<br>
</div></div></blockquote></div><br>