I think it depends on the tool.<div><br></div><div>Since tiger is still supported by webkit (it is in the buildbot), then any script that run during the build or running layout tests would need to run on python 2.3.5. (The version that shipped with Tiger.)</div>
<div><br></div><div>Some development still happens on Leopard (I think), so it seems like general development tools should support python 2.5.1.</div><div><br></div><div>dave<br><br><div class="gmail_quote">On Wed, Mar 3, 2010 at 3:27 PM, Chris Jerdonek <span dir="ltr">&lt;<a href="mailto:cjerdonek@webkit.org">cjerdonek@webkit.org</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Recently, there has been some off-list discussion about the minimum<br>
Python version WebKit should support (i.e. for the Python scripts in<br>
WebKitTools/Scripts).<br>
<br>
Up to this point, we haven&#39;t been explicit about it.  This ambiguity<br>
has occasionally caused things to break for people using versions<br>
before Python 2.6.<br>
<br>
It seems pretty clear that we at least want to support Python 2.5.<br>
The question that still remains is how many people are using Python<br>
2.4, and whether Python 2.4 is worth supporting.<br>
<br>
This thread collects a lot of the discussion:<br>
<br>
<a href="https://bugs.webkit.org/show_bug.cgi?id=35584" target="_blank">https://bugs.webkit.org/show_bug.cgi?id=35584</a><br>
<br>
Does anyone want us to support Python 2.4, or are people okay with Python 2.5?<br>
<br>
Thanks,<br>
--Chris<br>
_______________________________________________<br>
webkit-dev mailing list<br>
<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
<a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
</blockquote></div><br></div>