<meta charset="utf-8"><span class="Apple-style-span" style="font-family: arial, sans-serif; font-size: 13px; border-collapse: collapse; ">The only time I&#39;ve ever had an issue with committing is when I forgot to add the file myself.  The bot uses the same scripts that committers do.  I think it&#39;d be worth your time to become comfortable with them.  If nothing else, so you can land fixes for when you break the build.  It also frees up the queue for those who need it.  I&#39;d take another shot at landing yourself if I were you.</span><br>

<br><div class="gmail_quote">On Thu, Feb 25, 2010 at 1:17 AM, Kenneth Russell <span dir="ltr">&lt;<a href="mailto:kbr@google.com">kbr@google.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

<div class="im">On Wed, Feb 24, 2010 at 3:48 PM, David Levin &lt;<a href="mailto:levin@chromium.org">levin@chromium.org</a>&gt; wrote:<br>
</div><div class="im">&gt; 1. It looks like you are a committer, so you don&#39;t need to wait for the<br>
&gt; commit queue to do this for you :)<br>
<br>
</div>Understood -- but I prefer to use the bots where possible. I&#39;ve seen<br>
multiple instances where the commit scripts failed to add new files<br>
for some reason, but the bots have always been 100% reliable.<br>
<br>
-Ken<br>
<div><div></div><div class="h5"><br>
&gt; 2. But it still would be good to have this fixed. If you&#39;d like to help move<br>
&gt; this along, you can go to <a href="http://build.webkit.org/waterfall" target="_blank">http://build.webkit.org/waterfall</a> and find which<br>
&gt; patch caused the test to start failing. Then ping the relevant person.<br>
&gt;<br>
&gt; On Wed, Feb 24, 2010 at 3:41 PM, Kenneth Russell &lt;<a href="mailto:kbr@google.com">kbr@google.com</a>&gt; wrote:<br>
&gt;&gt;<br>
&gt;&gt; On Wed, Feb 24, 2010 at 12:02 PM, Alexey Proskuryakov &lt;<a href="mailto:ap@webkit.org">ap@webkit.org</a>&gt;<br>
&gt;&gt; wrote:<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; On 24.02.2010, at 11:47, David Levin wrote:<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; Actually, it doesn&#39;t appear to be do to recent changes in this<br>
&gt;&gt; &gt; area. They<br>
&gt;&gt; &gt; started failing after r55177<br>
&gt;&gt; &gt; (<a href="http://build.webkit.org/waterfall?last_time=1266975298" target="_blank">http://build.webkit.org/waterfall?last_time=1266975298</a>), but that<br>
&gt;&gt; &gt; change is<br>
&gt;&gt; &gt; unrelated to these test as far as I can tell.<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; It looks unrelated, but it somehow broke these editing tests<br>
&gt;&gt; &gt; nonetheless.<br>
&gt;&gt; &gt; I&#39;m investigating now.<br>
&gt;&gt;<br>
&gt;&gt; Thanks. Our patch (from <a href="https://bugs.webkit.org/show_bug.cgi?id=34459" target="_blank">https://bugs.webkit.org/show_bug.cgi?id=34459</a>)<br>
&gt;&gt; was about to be landed by the bot when the tree went red again. The<br>
&gt;&gt; test now failing is:<br>
&gt;&gt;<br>
&gt;&gt; fast/dom/prototype-inheritance-2.html -&gt; failed<br>
&gt;&gt;<br>
&gt;&gt; Could someone please look?<br>
&gt;&gt;<br>
&gt;&gt; Thanks,<br>
&gt;&gt;<br>
&gt;&gt; -Ken<br>
&gt;<br>
&gt;<br>
</div></div><div><div></div><div class="h5">_______________________________________________<br>
webkit-dev mailing list<br>
<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
<a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
</div></div></blockquote></div><br>