<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=gb2312">
<META content="MSHTML 6.00.2900.5921" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT size=2>Hi,All:</DIV>
<DIV>
<DIV>&nbsp;</DIV>
<DIV>I am trying to build WebKit-r53371 on windows. But now i am blocked with 
this error when&nbsp; build the webcore project:</DIV>
<DIV>&nbsp;</DIV>
<DIV><SPAN>Performing Pre-Link Event...</SPAN><BR><SPAN>Creating 
library...</SPAN><BR><SPAN>C:\cygwin\home\wupei\WebKit-r53371\webkitbuild\lib\<FONT 
color=#008000>WebCore.lib</FONT> : <FONT color=#008000>fatal error LNK1106: 
invalid file or disk full: cannot seek to 
0x5254F4AC</FONT></SPAN><BR><SPAN>Project : warning PRJ0018 : The following 
environment variables were not 
found:</SPAN><BR><SPAN>$(PRODUCTION)</SPAN><BR>$(DXSDK_DIR)<BR><SPAN></SPAN></DIV>
<DIV><SPAN>When I monitored the webcore.lib in the disk space, when "Creating 
library..." is in progress, </SPAN><BR><SPAN>WebKitBuild/lib/WebCore.lib is 
created and rapidly grows from a couple </SPAN><BR><SPAN>of megs to 128M, then 
to 256M, and at last to 512M, 1G. After LNK1106 error </SPAN><BR><SPAN>is 
displayed, the file is removed.</SPAN></DIV>
<DIV>
<P><SPAN><FONT color=#800000>Frist</FONT>, <SPAN>The disk has more than 10GB 
free space when build the webkit, so I think it isn't because of the free 
space.</SPAN></SPAN></P>
<P><SPAN><SPAN><FONT color=#800000>Second</FONT>, I have seen the <A 
href="">Bug&nbsp;19743</A> - <SPAN class=bz_default_hidden 
id=summary_alias_container style="DISPLAY: inline"><SPAN 
id=short_desc_nonedit_display>Release build fails on 32-bit Windows</SPAN> (<A 
href="">https://bugs.webkit.org/show_bug.cgi?id=19743</A>), but my version is 
newer than the bug fixed one.</SPAN></SPAN></SPAN></P>
<P><SPAN><SPAN><SPAN class=bz_default_hidden style="DISPLAY: inline"><FONT 
color=#800000>Third</FONT>, I have done update-webkit before 
build-webkit.</SPAN></SPAN></SPAN></P>
<P><SPAN><SPAN><SPAN class=bz_default_hidden style="DISPLAY: inline">And I also 
seen someone met the same problem in the network, but I can't search the 
solution.</SPAN></SPAN></SPAN></P>
<P><SPAN><SPAN><SPAN class=bz_default_hidden style="DISPLAY: inline">Dose anyone 
meet the same problem and have solved it? Will be appreciated for any 
comments.</SPAN></SPAN></SPAN></P>
<P><SPAN><SPAN><SPAN class=bz_default_hidden 
style="DISPLAY: inline"></SPAN></SPAN></SPAN>&nbsp;</P>
<P><SPAN><SPAN><SPAN class=bz_default_hidden 
style="DISPLAY: inline">WuPei</SPAN></SPAN></SPAN></P></DIV></FONT></DIV></BODY></HTML>