<div>As everyone may know, current webkit style (at least for most source code) for a switch statement is like this:</div>
<div> </div>
<div>switch (var) {</div>
<div>case valueFirst:</div>
<div>  ...</div>
<div>  break;</div>
<div>...</div>
<div>
<div>case valueLast:</div>
<div>  ...</div>
<div>  break;</div>
<div>default:</div>
<div>  ASSERT_NOT_REACHED()</div>
<div>}</div>
<div> </div>
<div>This looks good. But some compilers may give a warning like: &quot;statement is unreachable&quot;. Disabling this warning is a solution. But this warning can be helpful in some cases.</div>
<div> </div>
<div>So, how about changing the webkit style to this? </div>
<div> </div>
<div>
<div>switch (var) {</div>
<div>case valueFirst:</div>
<div>  ...</div>
<div>  break;</div>
<div>...</div>
<div>
<div>default:</div>
<div>
<div>  ASSERT(var == valueLast);</div>
<div>  ...</div>
<div>  break;</div>}</div></div></div></div>
<div> </div>
<div> </div>
<div>-Yong</div>