Thanks - I hadn&#39;t realized that about WebKit style.<br><br>I&#39;ve updated the interfaces to use different verbs (like &quot;createWorkerProxy()&quot;) or omit the verb entirely where appropriate.<br><br>-atw<br><br><div class="gmail_quote">
On Fri, May 22, 2009 at 12:30 PM, Darin Adler <span dir="ltr">&lt;<a href="mailto:darin@apple.com">darin@apple.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
No substantive comment, but a small style comment.<div class="im"><br>
<br>
On May 21, 2009, at 4:20 PM, Drew Wilson wrote:<br>
<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
  // Static factory method for getting the correct repository implementation for a given browser<br>
  static public SharedWorkerRepository* getRepository();<br>
</blockquote>
<br></div>
Generally WebKit does not use the verb &quot;get&quot; to name functions that simply return something. Instead for those we simply use a noun.<br>
<br>
If there is some real action involved, then we would want to use a verb, but not &quot;get&quot;. For example, if the function always creates something we can use the word create.<br>
<br>
Sadly we have not yet found a good verb for the common &quot;get or create&quot; idiom.<br><font color="#888888">
<br>
    -- Darin<br>
<br>
</font></blockquote></div><br>