<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div><div>On May 6, 2009, at 7:15 PM, Seby wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite">I've already tried to build the same after removing the WebKit Build directory and updating to latest source from svn. Do you meant to try reinstalling the MS VC++ Express and PlatformSDK?<br></blockquote><div><br></div>No, I meant to remove the WebKitBuild directory, like you said you did.</div><div><br></div><div>Are there any failures in the WebCoreGenerated project? That's the project that generates SVGNames.h.</div><div><br></div><div>-Adam</div><div><br><blockquote type="cite"><div>
<div class="gmail_quote">On Wed, May 6, 2009 at 2:46 PM, Adam Roben <span dir="ltr">&lt;<a href="mailto:aroben@apple.com">aroben@apple.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div style="word-wrap:break-word"><div><div class="im"><div>On May 6, 2009, at 2:41 PM, Seby wrote:</div><br><blockquote type="cite">Yes, That is the issue. It now fails at&nbsp;<span style="font-weight:bold">WebCore </span>and here is the errors:<div>
<br></div><div><table width="100%" bgcolor="#dfdfe5"><tbody><tr><td><font face="arial" size="+2">Output Window </font></td>
</tr></tbody></table><table cellspacing="0" cellpadding="0" width="*"><tbody><tr><td width="0" bgcolor="#ededf5">&nbsp;</td><td width="0" bgcolor="#ffffff">&nbsp;</td><td width="*"><pre>- - - -&nbsp;</pre><pre>- - - -</pre><pre>SVGResourceFilterCg.cpp
SVGResourceMasker.cpp
e:\cygwin\home\seby\webkit\webcore\svg\SVGElement.h(29) : fatal error C1083: Cannot open include file: 'SVGNames.h': No such file or directory
SVGResourceMarker.cpp
SVGResourceFilter.cpp
SVGResourceClipper.cpp
SVGResource.cpp
e:\cygwin\home\Seby\WebKit\WebCore\svg\SVGElement.h(29) : fatal error C1083: Cannot open include file: 'SVGNames.h': No such file or directory
SVGPaintServerSolid.cpp
SVGPaintServerRadialGradient.cpp
SVGPaintServerPattern.cpp
e:\cygwin\home\seby\webkit\webcore\svg\SVGElement.h(29) : fatal error C1083: Cannot open include file: 'SVGNames.h': No such file or directory
SVGPaintServerLinearGradient.cpp
</pre><pre>- - - - </pre><pre>- - - -</pre></td></tr></tbody></table><div><br></div><div>I can see these files in this directory using Windows Explorer or MyComputer. Do you think it is fails due to the upper/lower case issue of my home directory?</div>
</div></blockquote><div><br></div></div>I think you're seeing SVGNames.in, which is the filed used to generate SVGNames.h. Do you see any earlier errors in the WebCoreGenerated project about failing to generate this file? You might want to try doing a clean build now that you've gotten these other errors fixed.</div>
<div><br></div><font color="#888888"><div>-Adam</div></font><div><div></div><div class="h5"><div><br></div><div><blockquote type="cite"><div><div><div class="gmail_quote">On Wed, May 6, 2009 at 11:21 AM, Adam Roben <span dir="ltr">&lt;<a href="mailto:aroben@apple.com" target="_blank">aroben@apple.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div style="word-wrap:break-word">It looks like Cygwin's link.exe is getting invoked instead of VC++ Express's link.exe. I suspect you have an issue with your PATH. You could try adding the directory that contains VC++ Express's link.exe to your PATH.<div>

<br></div><div>-Adam</div><div><br><div><div><div></div><div><div>On May 6, 2009, at 5:33 AM, Seby wrote:</div><br></div></div><blockquote type="cite"><div><div></div><div><div class="gmail_quote"><span style="color:rgb(51, 102, 255)">Hello Adam,</span><div>

<span style="color:rgb(51, 102, 255)"><br></span></div><div><span style="color:rgb(51, 102, 255)">I tried to build WebKit using the latest version and I see that the "<span style="font-weight:bold">JavaScriptCoreGenerated</span>" without errors other than the xcopy error:</span><div>



<br></div><div><table width="100%" bgcolor="#dfdfe5"><tbody><tr><td><font face="arial" size="+2">Output Window </font></td></tr></tbody></table><table cellspacing="0" cellpadding="0" width="*"><tbody><tr><td width="0" bgcolor="#ededf5">



&nbsp;</td><td width="0" bgcolor="#ffffff">&nbsp;</td><td width="*"><div><pre><span style="color:rgb(102, 0, 0)">Performing Makefile project actions
 xcopy /y/d/e/i "..\..\..\WebKitLibraries\win\tools" "E:\cygwin\home\Seby\WebKit\WebKitLibraries\win\tools"
Cannot perform a cyclic copy
0 File(s) copied
 touch "E:\Build\buildfailed"</span></pre></div><pre><span style="color:rgb(102, 0, 0)">- - - - - - </span></pre><pre><span style="color:rgb(102, 0, 0)">logs omitted</span></pre>
<pre><span style="color:rgb(102, 0, 0)">- - - - - -</span></pre></td></tr></tbody></table><table width="100%" bgcolor="#dfdfe5"><tbody><tr><td><font face="arial" size="+2">Results </font></td></tr>
</tbody></table><table cellspacing="0" cellpadding="0" width="*"><tbody><tr><td width="0" bgcolor="#ededf5">&nbsp;</td><td width="0" bgcolor="#ffffff">&nbsp;</td><td width="*"><pre>Build log was saved at "<a>file://E:\Build\obj\JavaScriptCoreGenerated\Release\BuildLog.htm</a>"
JavaScriptCoreGenerated - 0 error(s), 0 warning(s)
</pre></td></tr></tbody></table><div class="gmail_quote"><br></div><div class="gmail_quote"><span style="color:rgb(51, 102, 255)">And the second one (<span style="font-weight:bold">record-memory-win</span>) failed w/ the link usage error as shown below:</span></div>



<div class="gmail_quote"><br></div><div class="gmail_quote"><table width="100%" bgcolor="#dfdfe5"><tbody><tr><td><font face="arial" size="+2">Output Window </font></td></tr></tbody></table><table cellspacing="0" cellpadding="0" width="*">



<tbody><tr><td width="0" bgcolor="#ededf5">&nbsp;</td><td width="0" bgcolor="#ffffff">&nbsp;</td><td width="*"><pre>Compiling...
main.cpp
Linking...
link: extra operand `/ERRORREPORT:QUEUE'
Try `link --help' for more information.
Project : error PRJ0002 : Error result 1 returned from 'E:\cygwin\bin\link.exe'.
</pre></td></tr></tbody></table><div><table width="100%" bgcolor="#dfdfe5"><tbody><tr><td><font face="arial" size="+2">Results </font></td></tr></tbody></table><table cellspacing="0" cellpadding="0" width="*">
<tbody><tr><td width="0" bgcolor="#ededf5">
&nbsp;</td><td width="0" bgcolor="#ffffff">&nbsp;</td><td width="*"><pre>Build log was saved at "<a>file://E:\Build\obj\record-memory-win\Release\BuildLog.htm</a>"
record-memory-win - 1 error(s), 0 warning(s)
</pre></td></tr></tbody></table></div></div><div class="gmail_quote"><br></div><div class="gmail_quote"><span style="color:rgb(51, 102, 255)">The thrid one (<span style="font-weight:bold">WTF</span>) was successful showing the below Result:</span></div>



<div class="gmail_quote"><span style="color:rgb(51, 102, 255)"><br></span></div><div class="gmail_quote"><table width="100%" bgcolor="#dfdfe5"><tbody><tr><td><font face="arial" size="+2">Results </font></td>
</tr></tbody></table><table cellspacing="0" cellpadding="0" width="*"><tbody><tr><td width="0" bgcolor="#ededf5">&nbsp;</td><td width="0" bgcolor="#ffffff">&nbsp;</td><td width="*"><pre>Build log was saved at "<a>file://E:\Build\obj\WTF\Release\BuildLog.htm</a>"
WTF - 0 error(s), 0 warning(s)
</pre></td></tr></tbody></table></div><div class="gmail_quote"><br></div><div class="gmail_quote"><span style="color:rgb(51, 102, 255)">And again the link error on&nbsp;</span><span style="font-weight:bold"><span style="color:rgb(51, 102, 255)">JavaScriptCore</span></span></div>



<div class="gmail_quote"><br></div><div class="gmail_quote"><table cellspacing="0" cellpadding="0" width="*"><tbody><tr><td width="*"><pre>Performing Pre-Link Event...
Linking...
link: missing operand after `/'
Try `link --help' for more information.
Project : error PRJ0002 : Error result 1 returned from 'E:\cygwin\bin\link.exe'.
Project : warning PRJ0018 : The following environment variables were not found:
$(PRODUCTION)
</pre></td></tr></tbody></table><table width="100%" bgcolor="#dfdfe5"><tbody><tr><td><font face="arial" size="+2">Results </font></td></tr></tbody></table><table cellspacing="0" cellpadding="0" width="*"><tbody><tr><td width="0" bgcolor="#ededf5">



&nbsp;</td><td width="0" bgcolor="#ffffff">&nbsp;</td><td width="*"><pre>Build log was saved at "<a>file://E:\Build\obj\JavaScriptCore\Release\BuildLog.htm</a>"
JavaScriptCore - 1 error(s), 0 warning(s)</pre></td></tr></tbody></table></div><div class="gmail_quote"><br></div><div class="gmail_quote"><span style="font-weight:bold"><span style="color:rgb(51, 102, 255)">WebCoreGenerated:</span></span><br>



</div><div class="gmail_quote"><br><table width="100%" bgcolor="#dfdfe5"><tbody><tr><td><font face="arial" size="+2">Output Window </font></td></tr></tbody></table><table cellspacing="0" cellpadding="0" width="*"><tbody><tr>



<td width="0" bgcolor="#ededf5">&nbsp;</td><td width="0" bgcolor="#ffffff">&nbsp;</td><td width="*"><pre>Performing Makefile project actions
Project : error PRJ0002 : Error result 1 returned from 'C:\WINDOWS\system32\cmd.exe'.
</pre></td></tr></tbody></table><table width="100%" bgcolor="#dfdfe5"><tbody><tr><td><font face="arial" size="+2">Results </font></td></tr></tbody></table><table cellspacing="0" cellpadding="0" width="*"><tbody><tr><td width="0" bgcolor="#ededf5">



&nbsp;</td><td width="0" bgcolor="#ffffff">&nbsp;</td><td width="*"><pre>Build log was saved at "<a>file://E:\Build\obj\WebCoreGenerated\Release\BuildLog.htm</a>"
WebCoreGenerated - 1 error(s), 0 warning(s)</pre></td></tr></tbody></table></div><div class="gmail_quote"><br></div><div class="gmail_quote"><span style="color:rgb(51, 102, 255)">and so on. The </span><span style="font-weight:bold"><span style="color:rgb(51, 102, 255)">WebCore</span></span><span style="color:rgb(51, 102, 255)"> BuildLog.htm showed a lot of errors (918). Please let me know if I'm missing any thing.</span></div>



<div class="gmail_quote"><span style="color:rgb(51, 102, 255)"><br></span></div><div class="gmail_quote"><span style="color:rgb(51, 102, 255)">Thanks,<br></span></div><font color="#888888">
<div class="gmail_quote"><span style="color:rgb(51, 102, 255)">Seby.</span></div></font><div><div></div><div><div class="gmail_quote"><br></div><div class="gmail_quote"><br></div><div class="gmail_quote">On Tue, May 5, 2009 at 11:59 AM, Adam Roben <span dir="ltr">&lt;<a href="mailto:aroben@apple.com" target="_blank">aroben@apple.com</a>&gt;</span> wrote:<br>



<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word"><div><div>On May 5, 2009, at 11:13 AM, Seby wrote:</div><br><blockquote type="cite">



<div>Any good news?</div></blockquote><div><br></div>Yes:</div><div><br></div><div><a href="http://trac.webkit.org/changeset/43239" target="_blank">http://trac.webkit.org/changeset/43239</a></div><div><br></div><div>Sorry for the delay. Let us know if you have any more trouble!</div>



<div><br></div><font color="#888888"><div>-Adam</div></font><div><div></div><div><div>.<blockquote type="cite"><div><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">




<div style="word-wrap:break-word"><div>Are you using VC++ Express? If so, you might be running into this bug:&nbsp;<a href="https://bugs.webkit.org/show_bug.cgi?id=25308" target="_blank">https://bugs.webkit.org/show_bug.cgi?id=25308</a></div>




<div><br></div><div>I'll try to land a fix for that bug today.</div><div><br></div><div>-Adam</div></div></blockquote></div></div></blockquote></div></div></div></div></blockquote></div></div></div></div></div></div>

</div></div>
_______________________________________________<div><br>webkit-dev mailing list<br><a href="mailto:webkit-dev@lists.webkit.org" target="_blank">webkit-dev@lists.webkit.org</a><br><a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>

</div></blockquote></div><br></div></div></blockquote></div><br></div></div>
</blockquote></div><br></div></div></div></blockquote></div><br></div>
</blockquote></div><br></body></html>