I don&#39;t know... this feels like a step back to me. &nbsp;While we&#39;ve made a ton of progress upstreaming changes, we still have more to upstream before we&#39;ll be able to build out of <a href="http://svn.webkit.org">svn.webkit.org</a>, so maybe disabling the bot temporarily is the right answer.<div>
<br></div><div>On the topic of build systems, I don&#39;t think the Chromium changes brewing there should matter much in the short term. &nbsp;I think we should push ahead making the scons build work and be useful.</div><div><br>
</div><div>If we do remove the bots from the front page, I hope everyone understands that we intend to re-enable them ASAP.</div><div><br></div><div>-Darin<br><br><div><br></div><div><br><div class="gmail_quote">On Mon, Jan 26, 2009 at 12:09 AM, Eric Seidel <span dir="ltr">&lt;<a href="mailto:eric@webkit.org">eric@webkit.org</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Sigh. &nbsp;Bounced again, silly gmail, the original message:<br>
<br>
On Mon, Jan 26, 2009 at 12:09 AM, Eric Seidel &lt;<a href="mailto:macdome@gmail.com">macdome@gmail.com</a>&gt; wrote:<br>
&gt; I suggest we turn them off. &nbsp;I can do that from our side.<br>
&gt;<br>
&gt; The bots should also be re-configured to not try and run the layout<br>
&gt; tests. &nbsp;They could run the JavaScriptCore tests, but I&#39;d have to fix<br>
&gt; run-javascriptcore-tests to find the binary.<br>
&gt;<br>
&gt; I would suggest we should just &quot;fix them&quot; instead of &quot;remove them&quot;,<br>
&gt; except for we&#39;re currently re-examining our build infrastructure, and<br>
&gt; so it&#39;s silly to hack on the <a href="http://webkit.org" target="_blank">webkit.org</a> copy more until we finish<br>
&gt; resolving our build questions @ <a href="http://chromium.org" target="_blank">chromium.org</a> first.<br>
&gt;<br>
&gt; If mark would like to just remove them from the config file, that is<br>
&gt; probably best. &nbsp;Thanks!<br>
&gt;<br>
&gt; -eric<br>
<div><div></div><div class="Wj3C7c">&gt;<br>
&gt; On Sun, Jan 25, 2009 at 11:38 PM, Darin Adler &lt;<a href="mailto:darin@apple.com">darin@apple.com</a>&gt; wrote:<br>
&gt;&gt; There are two Chromium bots in the open source WebKit buildbot.<br>
&gt;&gt;<br>
&gt;&gt; They permanently seem to say &quot;1077 regressions found&quot;. Also, since they<br>
&gt;&gt; build only JavaScriptCore at the moment, it seems, they are making it hard<br>
&gt;&gt; to read the rest of the buildbot output, because their build cycles are<br>
&gt;&gt; faster than all the rest and cause the other ones to stretch out a lot<br>
&gt;&gt; farther vertically. And despite only compiling JavaScriptCore, they also<br>
&gt;&gt; seem to be running a failing test called &quot;layout-test&quot;.<br>
&gt;&gt;<br>
&gt;&gt; Is there something we can do to make these useful or at least get them out<br>
&gt;&gt; of the way? At the moment they&#39;re always red and there&#39;s no way for folks<br>
&gt;&gt; working on WebKit to fix them and make them green.<br>
&gt;&gt;<br>
&gt;&gt; &nbsp; &nbsp;-- Darin<br>
&gt;&gt;<br>
&gt;&gt; _______________________________________________<br>
&gt;&gt; webkit-dev mailing list<br>
&gt;&gt; <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt;&gt; <a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
&gt;&gt;<br>
&gt;<br>
_______________________________________________<br>
webkit-dev mailing list<br>
<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
<a href="http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev</a><br>
</div></div></blockquote></div><br></div></div>