<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=utf-8">
<META content="MSHTML 6.00.2900.3395" name=GENERATOR></HEAD>
<BODY>
<DIV dir=ltr align=left><SPAN class=347412709-06112008><FONT face=Arial 
color=#0000ff size=2>Hi</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=347412709-06112008><FONT face=Arial 
color=#0000ff size=2></FONT></SPAN>&nbsp;</DIV>
<DIV dir=ltr align=left><SPAN class=347412709-06112008><FONT face=Arial 
color=#0000ff size=2>First you need to install safari first before starting the 
debug.</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=347412709-06112008><FONT face=Arial 
color=#0000ff size=2>There are two ways to debug..</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=347412709-06112008><FONT face=Arial 
color=#0000ff size=2>1. By running the debug command as you did below 
</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=347412709-06112008><FONT face=Arial 
color=#0000ff size=2>2. Open Visual C++ IDE and open the webkit project, then 
attach the safari.exe process to this project. And click on Debug 
option</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=347412709-06112008><FONT face=Arial 
color=#0000ff size=2></FONT></SPAN>&nbsp;</DIV>
<DIV dir=ltr align=left><SPAN class=347412709-06112008><FONT face=Arial 
color=#0000ff size=2>Thanks</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=347412709-06112008><FONT face=Arial 
color=#0000ff size=2>Sundar</FONT></SPAN></DIV><BR>
<DIV class=OutlookMessageHeader lang=en-us dir=ltr align=left>
<HR tabIndex=-1>
<FONT face=Tahoma size=2><B>From:</B> webkit-dev-bounces@lists.webkit.org 
[mailto:webkit-dev-bounces@lists.webkit.org] <B>On Behalf Of 
</B>???<BR><B>Sent:</B> Thursday, November 06, 2008 2:51 PM<BR><B>To:</B> 
webkit-dev@lists.webkit.org<BR><B>Subject:</B> [webkit-dev] debug the webkit 
with visual studio 2005<BR></FONT><BR></DIV>
<DIV></DIV>
<DIV>HI:</DIV>
<DIV>&nbsp;</DIV>
<DIV>&nbsp; I am an neebie, i want to debug the webkit with visual studio 
2005.now i&nbsp;have finished &nbsp;the steps:</DIV>
<DIV>&nbsp;</DIV>
<DIV>1、&nbsp;<A href="http://webkit.org/building/tools.html"><FONT 
color=#669922><STRONG>Installing the Developer Tools</STRONG></FONT></A><BR>2、<A 
href="http://webkit.org/building/checkout.html"><FONT 
color=#669922><STRONG>Getting WebKit</STRONG></FONT></A><BR>3、<A 
href="http://webkit.org/building/build.html"><STRONG><FONT 
color=#669922>Building WebKit</FONT></STRONG></A></DIV>
<DIV>&nbsp;</DIV>
<DIV>now i want to run webkit, i open a Cygwin Shell and type this command in 
the shell</DIV>
<DIV>WebKit/WebKitTools/Scripts/run-safari --debug</DIV>
<DIV>&nbsp;</DIV>
<DIV>but the result is:</DIV>
<DIV>ERROR:couldn't determine installed safari path</DIV>
<DIV>setting enviroments for using microsoft visual studio 2005 x86 tools</DIV>
<DIV>&nbsp;</DIV>
<DIV>&nbsp;</DIV>
<DIV>How can i debug the webkit step by step?</DIV>
<DIV>&nbsp;</DIV>
<DIV>thank you!</DIV></BODY></HTML>