<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=us-ascii">
<META content="MSHTML 6.00.2900.3354" name=GENERATOR></HEAD>
<BODY 
style="WORD-WRAP: break-word; webkit-nbsp-mode: space; webkit-line-break: after-white-space">
<DIV dir=ltr align=left><SPAN class=826112205-13082008><FONT face=Arial 
color=#0000ff size=2>Hi Binish,</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN 
class=826112205-13082008>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <FONT 
face=Arial color=#0000ff size=2>Another suggestion. Have you installed the <FONT 
color=#0000ff size=2>Platform SDK for Windows XP SP2 and ensured that you have 
added the paths for include, library and executables in your VC 
setup?</FONT></FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=826112205-13082008><FONT face=Arial 
color=#0000ff size=2></FONT></SPAN>&nbsp;</DIV>
<DIV dir=ltr align=left><SPAN class=826112205-13082008><FONT face=Arial 
color=#0000ff size=2>Regards,</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=826112205-13082008><FONT face=Arial 
color=#0000ff size=2>Tuheen</FONT></SPAN></DIV><BR>
<BLOCKQUOTE dir=ltr style="MARGIN-RIGHT: 0px">
  <DIV class=OutlookMessageHeader lang=en-us dir=ltr align=left>
  <HR tabIndex=-1>
  <FONT face=Tahoma size=2><B>From:</B> webkit-dev-bounces@lists.webkit.org 
  [mailto:webkit-dev-bounces@lists.webkit.org] <B>On Behalf Of </B>Adam 
  Roben<BR><B>Sent:</B> Wednesday, August 13, 2008 10:33 AM<BR><B>To:</B> 
  Binish<BR><B>Cc:</B> webkit-dev@lists.webkit.org<BR><B>Subject:</B> Re: 
  [webkit-dev] Compilation Erro usinf VC 2005 Express 
  Edition<BR></FONT><BR></DIV>
  <DIV></DIV>Try setting WEBKITOUTPUTDIR to a path beneath 
  E:\Cygwin\home\perforceadmin. That's how most users have things configured. If 
  that fixes things, please file a bug at bugs.webkit.org saying that the build 
  fails when WEBKITOUTPUTDIR is outside the home directory.
  <DIV><BR></DIV>
  <DIV>Thanks!</DIV>
  <DIV><BR></DIV>
  <DIV>-Adam</DIV>
  <DIV><BR>
  <DIV>
  <DIV>On Aug 13, 2008, at 12:02 AM, Binish wrote:</DIV><BR 
  class=Apple-interchange-newline>
  <BLOCKQUOTE type="cite">
    <DIV dir=ltr>Hi Adam,
    <DIV><BR></DIV>
    <DIV>I do set those variables, please find below my paths</DIV>
    <DIV>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</DIV>
    <DIV><BR></DIV>
    <DIV>
    <DIV>ALLUSERSPROFILE=C:\Documents and Settings\All Users.WINDOWS</DIV>
    <DIV>APPDATA=C:\Documents and Settings\perforceadmin.PERFORCE\Application 
    Data</DIV>
    <DIV>CLIENTNAME=CUBICLE78</DIV>
    <DIV>CommonProgramFiles=C:\Program Files\Common Files</DIV>
    <DIV>COMPUTERNAME=PERFORCE-VSS</DIV>
    <DIV>ComSpec=C:\WINDOWS\system32\cmd.exe</DIV>
    <DIV>FP_NO_HOST_CHECK=NO</DIV>
    <DIV>HOMEDRIVE=C:</DIV>
    <DIV>HOMEPATH=\Documents and Settings\perforceadmin.PERFORCE</DIV>
    <DIV>LOGONSERVER=\\PERFORCE-VSS</DIV>
    <DIV>NUMBER_OF_PROCESSORS=1</DIV>
    <DIV>OS=Windows_NT</DIV>
    <DIV>Path=C:\Perl\bin\;C:\PROGRA~1\Borland\CBUILD~1\Bin;C:\PROGRA~1\Borland\CBUILD~1\Projects\Bpl;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program 
    Files\Perforce;C:\Program Files\RSA Security\RSA SecurID Software 
    Token\;C:\Program Files\Microsoft SQL 
    Server\90\Tools\binn\;E:\Cygwin\bin;E:\Cygwin\usr\include\python2.5;ABHINAV 
    BINDRA ;C:\PROGRA~1\TTPCom\Alchemy;C:\Program Files\Vim\vim63</DIV>
    <DIV>PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH</DIV>
    <DIV>PROCESSOR_ARCHITECTURE=x86</DIV>
    <DIV>PROCESSOR_IDENTIFIER=x86 Family 15 Model 2 Stepping 9, 
    GenuineIntel</DIV>
    <DIV>PROCESSOR_LEVEL=15</DIV>
    <DIV>PROCESSOR_REVISION=0209</DIV>
    <DIV>ProgramFiles=C:\Program Files</DIV>
    <DIV>PROMPT=$P$G</DIV>
    <DIV>SESSIONNAME=RDP-Tcp#1</DIV>
    <DIV>SystemDrive=C:</DIV>
    <DIV>SystemRoot=C:\WINDOWS</DIV>
    <DIV>TEMP=C:\Documents and Settings\perforceadmin.PERFORCE\Local 
    Settings\Temp;</DIV>
    <DIV>TMP=C:\DOCUME~1\PERFOR~1.PER\LOCALS~1\Temp</DIV>
    <DIV>USERDOMAIN=PERFORCE-VSS</DIV>
    <DIV>USERNAME=perforceadmin</DIV>
    <DIV>USERPROFILE=C:\Documents and Settings\perforceadmin.PERFORCE</DIV>
    <DIV>VS80COMNTOOLS=E:\Program Files\Microsoft Visual Studio 
    8\Common7\Tools\</DIV>
    <DIV>WEBKITLIBRARIESDIR=E:\Cygwin\home\perforceadmin\WebKit\WebKitLibraries\win</DIV>
    <DIV>WEBKITOUTPUTDIR=D:\Webkit</DIV>
    <DIV>windir=C:\WINDOWS</DIV>
    <DIV>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</DIV>
    <DIV><BR></DIV>
    <DIV>Still getting the same errors as i mentioned 
    earlier&nbsp;like&nbsp;below&nbsp;</DIV>
    <DIV><BR></DIV>
    <DIV>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</DIV>
    <DIV>
    <DIV>DatePrototype.cpp</DIV>
    <DIV>..\..\kjs\DatePrototype.cpp(106) : fatal error C1083: Cannot open 
    include file: 'DatePrototype.lut.h': No such file or directory</DIV>
    <DIV>NumberConstructor.cpp</DIV>
    <DIV>..\..\kjs\NumberConstructor.cpp(24) : fatal error C1083: Cannot open 
    include file: 'NumberConstructor.lut.h': No such file or directory</DIV>
    <DIV>RegExpObject.cpp</DIV>
    <DIV>..\..\kjs\RegExpObject.cpp(23) : fatal error C1083: Cannot open include 
    file: 'RegExpObject.lut.h': No such file or directory</DIV>
    <DIV>StringPrototype.cpp</DIV>
    <DIV>..\..\kjs\StringPrototype.cpp(72) : fatal error C1083: Cannot open 
    include file: 'StringPrototype.lut.h': No such file or directory</DIV>
    <DIV>lexer.cpp</DIV>
    <DIV>..\..\kjs\lexer.cpp(48) : fatal error C1083: Cannot open include file: 
    'lexer.lut.h': No such file or directory</DIV>
    <DIV><BR></DIV>
    <DIV>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</DIV>
    <DIV>Any&nbsp;thoughts&nbsp;&nbsp;please?</DIV>
    <DIV><BR></DIV>
    <DIV>Thanks</DIV></DIV>
    <DIV><BR></DIV>
    <DIV><BR></DIV><BR>
    <DIV class=gmail_quote>2008/8/11 Adam Roben <SPAN dir=ltr>&lt;<A 
    href="mailto:aroben@apple.com">aroben@apple.com</A>&gt;</SPAN><BR>
    <BLOCKQUOTE class=gmail_quote 
    style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">
      <DIV class=Ih2E3d><BR>On Aug 11, 2008, at 10:41 AM, Binish wrote:<BR><BR>
      <BLOCKQUOTE class=gmail_quote 
      style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">Hi 
        Adam,<BR><BR>I have already tried configuring both in a diffenrent 
        location , and result remains same , sorry i did not get about 
        build-webkit !,From VC tools menu i directly give "build solution" am 
        not runnign from cygwin,Using cygwin i was able to compile 
        successfully.<BR>Now i feel that "autogenarated" files are not gettign 
        created ...!!.<BR><BR>Any suggestions please 
      ..<BR></BLOCKQUOTE><BR></DIV>If you want to build from Visual Studio, you 
      need to set the WEBKITLIBRARIESDIR and WEBKITOUTPUTDIR environment 
      variables. You should set these variables to the values that build-webkit 
      sets them to. build-webkit prints out the values when it starts the build, 
      so you should be able to copy and paste them.<BR><FONT 
      color=#888888><BR>-Adam<BR><BR></FONT></BLOCKQUOTE></DIV><BR></DIV></DIV></BLOCKQUOTE></DIV><BR></DIV></BLOCKQUOTE></BODY></HTML>