<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
Khanna Piyush-A21612 wrote:
<blockquote
 cite="mid:3100473D52017B48B9068E079BE2A6E602E76ED8@ZMY16EXM67.ds.mot.com"
 type="cite">
  <meta http-equiv="Content-Type" content="text/html; ">
  <meta content="MSHTML 6.00.2900.3268" name="GENERATOR">
  <div dir="ltr" align="left"><font color="#0000ff" face="Arial"
 size="2"><span class="593511211-31032008">An update...</span></font></div>
  <div dir="ltr" align="left"><font color="#0000ff" face="Arial"
 size="2"><span class="593511211-31032008"></span></font>&nbsp;</div>
  <div dir="ltr" align="left"><font face="Arial"><font color="#0000ff"><font
 size="2"><font><span class="593511211-31032008">After setting the
WebKitLibrariesDir &amp; WebKitOutputDir environment variables using </span></font>Control
Panel<span class="593511211-31032008">, the<font color="#000000">&nbsp;C:\cygwin\home\a21612\WebKit\WebKitTools\WinLauncher\WinLauncher.vcproj</font><font
 color="#0000ff">&nbsp;project opened successfully</font></span></font></font></font></div>
  <div dir="ltr" align="left"><font face="Arial"><font color="#0000ff"><font
 size="2"><span class="593511211-31032008"></span></font></font></font>&nbsp;</div>
  <div dir="ltr" align="left"><font face="Arial"><font color="#0000ff"><font
 size="2"><span class="593511211-31032008"><font color="#0000ff">However,
that seems to have very few files (i.e. not the entire webkit).</font></span></font></font></font></div>
</blockquote>
<br>
You should instead be building WebKit.sln (located at
WebKit/WebKit/win/WebKit.vcproj/WebKit.sln).<br>
<br>
<blockquote
 cite="mid:3100473D52017B48B9068E079BE2A6E602E76ED8@ZMY16EXM67.ds.mot.com"
 type="cite">
  <div dir="ltr" align="left"><font face="Arial"><font color="#0000ff"><font
 size="2"><span class="593511211-31032008"><font color="#0000ff"> Also
building the same returned error (which again mentions some
uninitialized environment variables). Attached is the log output.</font></span></font></font></font></div>
</blockquote>
<br>
The warning about $(PRODUCTION) is expected and should not cause a
problem. Your build log complains that WebKit.h is missing, but that's
because you haven't build WebKit yet. To do so, build WebKit.sln as
mentioned above.<br>
<br>
-Adam<br>
<br>
</body>
</html>