<html>
<head>
<style>
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
FONT-SIZE: 10pt;
FONT-FAMILY:Tahoma
}
</style>
</head>
<body class='hmmessage'>Sorry, my mistake. code from SVN does have pthread header.<BR><BR><BR><BR>
<BLOCKQUOTE>
<HR id=EC_stopSpelling>
From: ijshusky@hotmail.com<BR>To: bfulgham@gmail.com<BR>Date: Wed, 20 Feb 2008 07:17:43 +0000<BR>CC: webkit-dev@lists.webkit.org<BR>Subject: Re: [webkit-dev] Help needed. WebKit with Windows XP<BR><BR>
<META content="Microsoft SafeHTML" name=Generator>
<STYLE>
.ExternalClass .EC_hmmessage P
{padding:0px;}
.ExternalClass EC_body.hmmessage
{font-size:10pt;font-family:Tahoma;}
</STYLE>

<DIV>Hi Brent,<BR><BR>On mine&nbsp;the&nbsp;'env'&nbsp;says:</DIV>
<DIV>&nbsp;</DIV>
<DIV>WEBKITLIBRARIESDIR=E:\WebKit\WebKitLibraries\win</DIV>
<DIV>WEBKITOUTPUTDIR=E:\WebKit\WebKitBuild</DIV>
<DIV>&nbsp;</DIV>
<DIV>I think I should have set the variables correctly.<BR><BR>I have had my code downloaded from both the nightly-build and through svn. There is no pthread headers from either. The compiler also complains there is no 'unicode/uchar.h'.</DIV>
<DIV>&nbsp;</DIV>
<DIV>There is another new problem. I was just trying to run winLauncher.patch, those 2 ico files cannot be patched for some reason. From Cygwin I use "patch -p0 &lt; winLauncher.patch".</DIV>
<DIV>&nbsp;</DIV>
<DIV>cheers,</DIV>
<DIV>Ivan</DIV>
<BLOCKQUOTE>
<HR id=EC_EC_stopSpelling>
CC: webkit-dev@lists.webkit.org<BR>From: bfulgham@gmail.com<BR>To: ijshusky@hotmail.com<BR>Subject: Re: [webkit-dev] Help needed. WebKit with Windows XP<BR>Date: Tue, 19 Feb 2008 23:01:36 -0800<BR><BR>Ivan, 
<DIV><BR class=EC_EC_webkit-block-placeholder></DIV>
<DIV>Problem #2 indicates that the build cannot find the pthread headers. &nbsp;These are installed as part of Apple's WebKitLibraries directory. &nbsp;Most likely, you do not have the environment variables set, or you have not been running the "update-webkit" script.</DIV>
<DIV><BR class=EC_EC_webkit-block-placeholder></DIV>
<DIV>From the cygwin console, what does 'env' show?</DIV>
<DIV><BR class=EC_EC_webkit-block-placeholder></DIV>
<DIV>On my system, I get a few entries including:</DIV>
<DIV>WEBKITLIBRARIESDIR=C:\Fulgham\WebKit\WebKitLibraries\win</DIV>
<DIV>WEBKITOUTPUTDIR=C:\Fulgham\WebKit\WebKitBuild</DIV>
<DIV><BR class=EC_EC_webkit-block-placeholder></DIV>
<DIV>Do your entries have spaces in the path names perhaps?</DIV>
<DIV><BR class=EC_EC_webkit-block-placeholder></DIV>
<DIV>-Brent</DIV>
<DIV><BR>
<DIV>
<DIV>On Feb 19, 2008, at 9:10 PM, Ivan Shusky wrote:</DIV><BR class=EC_EC_Apple-interchange-newline>
<BLOCKQUOTE><SPAN class=EC_EC_Apple-style-span style="WORD-SPACING: 0px; FONT: 12px Helvetica; TEXT-TRANSFORM: none; COLOR: rgb(0,0,0); TEXT-INDENT: 0px; WHITE-SPACE: normal; LETTER-SPACING: normal; BORDER-COLLAPSE: separate">
<DIV class=EC_EC_hmmessage style="FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">
<DIV>Hi Brent,</DIV>
<DIV>&nbsp;</DIV>
<DIV>Thank you for your timely reply. I did set those environment variables but it did not work. Not sure what was wrong. I have deleted the entire project&nbsp;to start fresh&nbsp;for&nbsp;another run&nbsp;and it works.<BR><BR>I currently still have 2 problems.</DIV>
<DIV>&nbsp;</DIV>
<DIV>1)&nbsp;When try to&nbsp;patch file "webcore_win32fonts.patch", I got error saying:</DIV>
<DIV>&nbsp;</DIV>
<DIV>can't find file to patch at input li<BR>Perhaps you used the wrong -p or --s<BR>The text leading up to this was:<BR>--------------------------<BR>|Index: ChangeLog<BR>|===================================<BR>|--- ChangeLog&nbsp; (revision 30391)<BR>|+++ ChangeLog&nbsp; (working copy)<BR>--------------------------""</DIV>
<DIV>&nbsp;</DIV>
<DIV>2) When I try to build the entire project I got this error message&nbsp;"fatal error C1083: Cannot open include file: 'pthread.h': No such file or directory".</DIV>
<DIV>&nbsp;</DIV>
<DIV><BR>Best,</DIV>
<DIV>Ivan<BR></DIV><BR>
<HR>
Express yourself instantly with MSN Messenger!<SPAN class=EC_EC_Apple-converted-space>&nbsp;</SPAN><A href="http://clk.atdmt.com/AVE/go/onm00200471ave/direct/01/" target=_blank>MSN Messenger</A></DIV></SPAN></BLOCKQUOTE></DIV><BR></DIV></BLOCKQUOTE><BR>
<HR>
Express yourself instantly with MSN Messenger! <A href="http://clk.atdmt.com/AVE/go/onm00200471ave/direct/01/" target=_blank>MSN Messenger</A> </BLOCKQUOTE><br /><hr />Express yourself instantly with MSN Messenger! <a href='http://clk.atdmt.com/AVE/go/onm00200471ave/direct/01/' target='_new'>MSN Messenger</a></body>
</html>