<br>Hello Kevin, unfortunately I&#39;m getting the same errors again. I updated my code to revision 28828 and I installed all packages/deps you told me on the irc channel. I listed them below:<br><br>Package: gcc Version: 4:
4.1.2-9ubuntu2<br>Package: g++ Version: 4:4.1.2-9ubuntu2<br>Package: libgnome-dev Version: 1.4.2-36<br>Package: flex Version: 2.5.33-12build1<br>Package: bison Version: 1:2.3.dfsg-5<br>Package: gperf Version: 3.0.3-1<br>Package: libxml2 Version: 
2.6.30.dfsg-2ubuntu1<br>Package: libxslt1.1 Version: 1.1.21-2ubuntu2<br>Package: libxslt1-dev Version: 1.1.21-2ubuntu2<br>Package: libicu36 Version: 3.6-3<br>Package: libicu36-dev Version: 3.6-3<br>Package: libcurl4-openssl-dev Version: 
7.16.4-2ubuntu1<br>Package: libsqlite3-dev Version: 3.4.2-1build1<br>Package: libpng12-dev Version: 1.2.15~beta5-2ubuntu0.1<br>Package: libjpeg62-dev Version: 6b-14<br>Package: python-wxgtk2.8 Version: 2.8.4.0-0ubuntu3<br>
Package: python-wxtools Version: 2.8.4.0-0ubuntu3<br>Package: python-wxaddons Version: 2.8.4.0-0ubuntu3<br>Package: wx2.8-i18n Version: 2.8.4.0-0ubuntu3<br>Package: python-dev Version: 2.5.1-1ubuntu2<br>Package: wx-common Version: 
2.8.4.0-0ubuntu3<br>Package: libpango1.0-dev Version: 1.18.3-0ubuntu1<br>Package: libgtk2.0-dev Version: 2.12.0-1ubuntu3<br><br>Also, after running&nbsp; &#39;icu-config --ldflags&#39; I got:&nbsp; -lpthread -lm -L/usr/lib -licui18n -licuuc -licudata -lpthread -lm
<br><br>Thanks<br>--<br>r<br><br><div><span class="gmail_quote">On 12/17/07, <b class="gmail_sendername">Kevin Ollivier</b> &lt;<a href="mailto:kevino@theolliviers.com" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
kevino@theolliviers.com</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Hi Rodrigo,<br><br>On Dec 17, 2007, at 11:46 AM, Rodrigo Melo wrote:<br><br>&gt; Hello folks, I&#39;m facing some issues to build webkit for wx.&nbsp;&nbsp;The<br>&gt; output shows some link libraries errors as shown below.<br>&gt;
<br>&gt; ~/mydev/WebKitBuild/Release/libjscore.a(jscore_collector.o): In<br>&gt; function `KJS::currentThreadStackBase()&#39;:<br>&gt; ~/mydev/JavaScriptCore/kjs/collector.cpp:350: undefined reference to<br>&gt; `pthread_getattr_np&#39;
<br>&gt; ~/mydev/JavaScriptCore/kjs/collector.cpp:352: undefined reference to<br>&gt; `pthread_attr_getstack&#39;<br>&gt; ~/mydev/WebKitBuild/Release/libjscore.a(jscore_function.o): In<br>&gt; function `WTF::Unicode::isSeparatorSpace(int)&#39;:
<br>&gt; ~/mydev/JavaScriptCore/./wtf/unicode/icu/UnicodeIcu.h:172: undefined<br>&gt; reference to `u_charType_3_6&#39;<br>&gt; ~/mydev/WebKitBuild/Release/libjscore.a(jscore_lexer.o): In function<br>&gt; `WTF::Unicode::category(int)&#39;:
<br>&gt; ~/mydev/JavaScriptCore/./wtf/unicode/icu/UnicodeIcu.h:197: undefined<br>&gt; reference to `u_charType_3_6&#39;<br>&gt; ~/mydev/WebKitBuild/Release/libjscore.a(jscore_nodes2string.o): In<br>&gt; function `WTF::Unicode::isPrintableChar(int)&#39;:
<br>&gt; ~/mydev/JavaScriptCore/./wtf/unicode/icu/UnicodeIcu.h:177: undefined<br>&gt; reference to `u_isprint_3_6&#39;<br>&gt; ~/mydev/WebKitBuild/Release/libjscore.a(jscore_string_object.o): In<br>&gt; function `WTF::Unicode::toUpper(unsigned short*, int, unsigned short
<br>&gt; const*, int, bool*)&#39;:<br>&gt; ~/mydev/JavaScriptCore/./wtf/unicode/icu/UnicodeIcu.h:155: undefined<br>&gt; reference to `u_strToUpper_3_6&#39;<br>&gt; ~/mydev/WebKitBuild/Release/libjscore.a(jscore_string_object.o): In
<br>&gt; function `WTF::Unicode::toLower(unsigned short*, int, unsigned short<br>&gt; const*, int, bool*)&#39;:<br>&gt; ~/mydev/JavaScriptCore/./wtf/unicode/icu/UnicodeIcu.h:137: undefined<br>&gt; reference to `u_strToLower_3_6&#39;
<br>&gt; collect2: ld returned 1 exit status<br>&gt; make: *** [~/mydev/WebKitBuild/Release/testkjs] Error 1<br>&gt; make: Leaving directory `~/mydev/JavaScriptCore&#39;<br>&gt;<br>&gt;<br>&gt; Anyone has already got this issue? Any idea?
<br><br>I just did a svn update and built on Ubuntu Gutsy successfully, so I&#39;m<br>fairly certain that with a clean tree and the right dependencies, you<br>should be able to perform a successful build. The u_* symbols are ICU-
<br>related, and for the wx build the ICU libs are gotten by using `icu-<br>config --ldflags` on Linux. What happens when you run that command on<br>your box?<br><br>For me, it returns several ICU libs, and also has -lpthread, so that
<br>probably explains why the pthread symbols are missing for you too.<br><br>Thanks,<br><br>Kevin<br><br>&gt;<br>&gt; Thanks in advance<br>&gt;<br>&gt; --<br>&gt; romelo<br>&gt; _______________________________________________
<br>&gt; webkit-dev mailing list<br>&gt; <a href="mailto:webkit-dev@lists.webkit.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">webkit-dev@lists.webkit.org</a><br>&gt; <a href="http://lists.webkit.org/mailman/listinfo/webkit-dev" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
http://lists.webkit.org/mailman/listinfo/webkit-dev
</a><br><br></blockquote></div><br>