[webkit-dev] Terminology: Could we change 'roll out' to 'roll back'?

Kirsling, Ross Ross.Kirsling at sony.com
Fri Mar 6 18:38:29 PST 2020

I'd be thrilled for us to use 'revert'.
Somehow I'd convinced myself that it'd be easier to ask for this if we kept the 'roll' part, but I'm not really sure why I thought so.

Of course, it's fine for folks to continue to _say_ 'roll out' due to habit; I just think it would be great if our automated 'rollouts' turned into automated 'reverts' instead.


On 3/6/20, 6:31 PM, "Ryosuke Niwa" <rniwa at webkit.org> wrote:

    On Fri, Mar 6, 2020 at 6:15 PM Kirsling, Ross <Ross.Kirsling at sony.com> wrote:
    > Late on Friday seems like a good time for a terminological debate (), so I’d like to propose we revisit one of the strangest items of WebKit-specific terminology: the phrase ‘roll out’.
    > In our industry, the typical meaning of the phrase ‘roll out’ is, of course, ‘deploy’ or ‘launch’; this corresponds with the colloquial usage of ‘roll out’ to mean ‘depart (for a destination)’. In WebKit, we use ‘roll out’ to mean the exact opposite, ‘revert’ or ‘roll back’.
    I think the ship has sailed on this one. People who have been working
    on the WebKit project for long enough are so used to the phrase
    "rollout a patch" that it's gonna be tricky to change the terminology.
    Having said that, I'd much prefer the term "revert" over "rollout" or
    "rollback". It's also the term git uses.
    > This term is confusing enough for native English speakers outside our community, let alone non-natives (since phrasal verbs are notoriously tricky as it is).
    As a non-native speaker myself, I never find this term confusing
    because I have no mental model of what "rollout" or "rollback" means.
    However, I find those two terms infinitely more confusing than the
    very direct "revert".
    - R. Niwa

More information about the webkit-dev mailing list