[webkit-dev] Naming convention for static member variables

Konstantin Tokarev annulen at yandex.ru
Wed Feb 19 11:39:32 PST 2020

19.02.2020, 22:31, "Simon Fraser" <simon.fraser at apple.com>:
> class Foo {
>   static bool thing.
> };
> What's the naming convention for static member variables like this? I've seen m_foo, which seems positively harmful. I've seen s_foo, which I like.
> There are 165 instances of s_ that I can find in the project. There are 17 instances of static m_.

According to [1], convention is "s_". Apparently, it just lacks an enforcement in style checker.

[1] https://webkit.org/code-style-guidelines/#names-data-members


More information about the webkit-dev mailing list