[webkit-dev] Rename wtf/unicode/UTF8.h
fujii.hironori at gmail.com
Wed Oct 31 20:04:12 PDT 2018
Thank you for the feedback, Konstantin and Darin.
On Thu, Nov 1, 2018 at 1:52 AM Darin Adler <darin at apple.com> wrote:
> With a few seconds thought I am thinking that maybe UTF8Conversion.h or
> UTF8Transcoding.h are possible better ideas for new names. Neither is
> completely accurate. If we were going to add the word “helpers” than I
> would say UTF8Helpers.h, but I really don’t like those kinds of word in
> header names (“utilities”, “helpers”, “functions”, “classes”).
Sounds good. I take UTF8Conversion.h.
> A separate issue once we rename: the header is also pretty old and crufty.
> Eventually we might want to remove or refine the functions in here. Not
> sure how widely they are used.
There are 8 functions in the header.
Following 2 functions are used only in
Following 3 functions are used only in WTF/wtf/text/AtomicStringImpl.cpp
Following 3 functions are widely used
Any suggestions are welcome to improve.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev