[webkit-dev] the name "AtomicString"

Ryosuke Niwa rniwa at webkit.org
Wed Dec 19 20:06:19 PST 2018

On Wed, Dec 19, 2018 at 1:13 PM Simon Fraser <simon.fraser at apple.com> wrote:

> > On Dec 19, 2018, at 12:33 PM, Michael Catanzaro <mcatanzaro at igalia.com>
> wrote:
> >
> > On Tue, Dec 18, 2018 at 9:31 PM, Darin Adler <darin at apple.com> wrote:
> >> I’ve gotten used to the name AtomicString over the years, but I
> wouldn’t strongly object to changing it if other programmers are often
> confused by it’s similarity to the term “atomic operations”.
> >
> > Well there were two other developers in the thread Ryosuke linked to who
> made the exact same mistake as me, so I do think the current name is
> problematic. A change wouldn't need to be drastic, though. I think
> suggestions from the old thread like "StringAtom" or "AtomString" would be
> unproblematic. The problem is the specific word "atomic" carries an
> expectation that the object be safe to access concurrently across threads
> without locks; I think that expectation doesn't exist if not for the "ic"
> at the end.
> >
> > FWIW I've only ever heard the "interned string" terminology prior to now.
> SingletonString?
> UniquedString?

I do like UniquedString. That conveys what AtomicString really is.
SingletonString isn't so great since AtomicString table is still per thread.

> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20181219/b0b195a5/attachment.html>

More information about the webkit-dev mailing list