[webkit-dev] the name "AtomicString"
mjs at apple.com
Wed Dec 19 14:37:10 PST 2018
> On Dec 19, 2018, at 12:33 PM, Michael Catanzaro <mcatanzaro at igalia.com> wrote:
> On Tue, Dec 18, 2018 at 9:31 PM, Darin Adler <darin at apple.com> wrote:
>> I’ve gotten used to the name AtomicString over the years, but I wouldn’t strongly object to changing it if other programmers are often confused by it’s similarity to the term “atomic operations”.
> Well there were two other developers in the thread Ryosuke linked to who made the exact same mistake as me, so I do think the current name is problematic. A change wouldn't need to be drastic, though. I think suggestions from the old thread like "StringAtom" or "AtomString" would be unproblematic. The problem is the specific word "atomic" carries an expectation that the object be safe to access concurrently across threads without locks; I think that expectation doesn't exist if not for the "ic" at the end.
> FWIW I've only ever heard the "interned string" terminology prior to now.
On balance, if we change, I’d lean towards Atom, since it is concise, obviously mysterious if you don’t know what it is, and understandable to at least some people who have seem that name for the concept. The only downside is that it’s not obvious from the name that it is a kind of string.
More information about the webkit-dev