[webkit-dev] Rename LayoutTests

Konstantin Tokarev annulen at yandex.ru
Wed May 10 02:51:04 PDT 2017

10.05.2017, 12:42, "Ryosuke Niwa" <rniwa at webkit.org>:
> On Wed, May 10, 2017 at 2:14 AM, Ryosuke Niwa <rniwa at webkit.org> wrote:
>>  On Wed, May 10, 2017 at 12:02 AM, Maciej Stachowiak <mjs at apple.com> wrote:
>>>  IntegrationTests doesn't distinguish them from performance tests, or API
>>>  tests. And most test integration only incidentally. FunctionalTests doesn't
>>>  distinguish them from any of the other kinds of tests besides performance
>>>  tests.
>>>  I think just plain Tests is better than calling out a characteristic that
>>>  isn't actually unique. It's by far the most common type of test we have, so
>>>  it's ok for it to be the unmarked category.
>>  The problem with Tests is that it competes with Tools.
>>  (Renaming Tools is a lot harder not to mention it's a pretty
>>  descriptive name already).
>>  How about CorrectnessTests or CoreTests then?
> I guess another name along this line would be RegressionTests.

Why not just keep historical name, so nobody is confused what is what?

>>>  I think the only names that are both accurate and unique are likely to be
>>>  bad for autocomplete (WebTests, WebContentTests, etc).
>>  I guess we can also move WebKit.xcworkspace into Source, and rename
>>  WebKitLibraries to SystemInterfaceLibraries (and maybe move into
>>  Source), and then move Websites into Tools.
>>  - R. Niwa
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev


More information about the webkit-dev mailing list