[webkit-dev] Rename LayoutTests
Manuel Rego Casasnovas
rego at igalia.com
Tue May 9 22:29:27 PDT 2017
On 10/05/17 04:23, Ryosuke Niwa wrote:
> Continuing the tradition of a massive rename in
> I suggest we rename the top-level LayoutTests directory to something
> more descriptive of the current state.
> Some ideas:
> IntegrationTests - Represents what they are for WebCore.
> AutomatedTests - As opposed to ManualTests.
> ContentTests - Not great for tab completion.
> WebTests - Probably a bad idea for tab completion.
The very same discussion is happening right now on blink-dev:
A document with some ideas and pros/cons of each one:
BTW, on a first sight I like "WebTests/" or even "Tests/".
More information about the webkit-dev