[webkit-dev] Unified source builds: A new rule for static variables

Michael Catanzaro mcatanzaro at igalia.com
Tue Aug 29 12:28:01 PDT 2017

On Tue, Aug 29, 2017 at 1:37 PM, Maciej Stachowiak <mjs at apple.com> 
> I tend to agree with this. I think keeping names of static functions 
> globally unique is reasonable, so long as we have an automated way to 
> check. This seems better than namespaces. With namespaces, it's still 
> possible to make a mistake, such as by having a using at global 
> scope, so we'd need the style checker to enforce some kind of rule.
> If we were to use namespaces, then properly naming them seems better 
> than the FILENAME macro.


I posted a somewhat different proposal in the other thread, suggesting 
that we manually decide which files to unify together so that we only 
need to keep names of static functions unique to a particular unified 
source bundle. That would be easier than keeping the names 
globally-unique, but would complicate the build system. Either way 
would be fine I think: I'm really just hoping to avoid the need to 
adopt this namespace FILENAME rule. :)


More information about the webkit-dev mailing list