[webkit-dev] [CMake] Bumping cmake_minimum_required

Fujii Hironori fujii.hironori at gmail.com
Fri Sep 23 06:08:08 PDT 2016

On Fri, Sep 23, 2016 at 5:14 PM, Konstantin Tokarev <annulen at yandex.ru> wrote:
> 23.09.2016, 00:59, "Alex Christensen" <achristensen at apple.com>:
>> Requiring CMake 3.0 would not cause us a problem.
> Looks like anyone is fine with updating CMake to 3.0, however Fujii Hironori is asking about CMake 3.2, and AFAIU updating to 3.0 won't help for his patch.
> .

That's right.
Debian 9 will be released in 2017. <https://wiki.debian.org/DebianStretch>
One year after Debian 9 is released, CMake 3.5 will the minimum
version to be supported, which is included in Ubuntu 16.4.
I can not wait for that.
I will take the approach of switching by CMAKE_VERSION like the following code.


Thank you.

Hironori.Fujii at sony.com  Sony Interactive Entertainment

More information about the webkit-dev mailing list