[webkit-dev] Proposal: Use #pragma once instead of header guards
andersca at apple.com
Wed Mar 9 18:47:43 PST 2016
Yeah, I agree.
> On Mar 9, 2016, at 6:46 PM, Michael Catanzaro <mcatanzaro at igalia.com> wrote:
> On Wed, 2016-03-09 at 17:27 -0800, Anders Carlsson wrote:
>> Hi floks,
>> Currently we use
>> #ifndef Header_h
>> #define Header_h
>> I propose that we instead start using
>> #pragma once
>> which does the same thing.
> I think it's fine for the GTK port in general, but it would be nice to
> keep this out of our public headers. That is mostly just GTK-specific
> JSBase.h, JSContextRef.h, JSObjectRef.h, JSStringRef.h, JSValueRef.h,
> and WebKitAvailability.h.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev