[webkit-dev] Proposal: Use #pragma once instead of header guards
andersca at apple.com
Wed Mar 9 17:34:51 PST 2016
I think we should put it where we currently have the header guard. I think the pragma is easier to understand than a #ifndef/#define.
> On Mar 9, 2016, at 5:33 PM, Brian Burg <bburg at apple.com> wrote:
> Cool! It sounds like something good for new headers and drive-by cleanups, to start.
> To clarify, it would always go after the license block? Is the pragma name stable and understandable enough to paste everywhere?
>> On Mar 9, 2016, at 17:27, Anders Carlsson <andersca at apple.com> wrote:
>> Hi floks,
>> Currently we use
>> #ifndef Header_h
>> #define Header_h
>> I propose that we instead start using
>> #pragma once
>> which does the same thing. It can be faster on some compilers, is less error prone and is one line instead of three! All compilers we use support #pragma once.
>> - Anders
>> webkit-dev mailing list
>> webkit-dev at lists.webkit.org
More information about the webkit-dev