[webkit-dev] Should overridden methods use 'virtual' keyword in addition to 'override'?
darin at apple.com
Fri Mar 4 10:32:00 PST 2016
Here are three other loose ends I am thinking about:
- Style guide should say that in a class marked final, virtual functions should all be marked final, not override and certainly not virtual. Agreed? Can we check that with the script? Apply that rule globally like we just did with the other rules with do-webcore-rename?
- Style guide should encourage programmers to use final instead of override whenever possible. I suspect many of the functions that currently are tagged override should be final instead. Agreed?
- Style guide should discourage virtual on destructors where the destructor is already virtual due to a base class. This is now more consistent with the use of virtual on other member functions, final would be on the class, override doesn’t need to be stated. Agreed?
More information about the webkit-dev