[webkit-dev] Naming preference: SetForScope vs. TemporaryChange

Michael Catanzaro mcatanzaro at igalia.com
Fri Dec 23 06:32:27 PST 2016

On Fri, 2016-12-23 at 05:42 +0000, Yusuke SUZUKI wrote:
> Personally I like the name "SetForScope" since the name "scope"
> states that this value change is tied to C++ scope.

Me too. The name is pretty clear. The first time I saw TemporaryChange
I had to look at the implementation to see what it did.


More information about the webkit-dev mailing list