[webkit-dev] Naming preference: SetForScope vs. TemporaryChange

Saam barati sbarati at apple.com
Thu Dec 22 18:27:59 PST 2016

Hi all,

Recently, Yusuke found that JSC and WTF both had the exact same RAII helper data structure. JSC called it SetForScope, and WTF called it TemporaryChange. (Details here: https://bugs.webkit.org/show_bug.cgi?id=164761 <https://bugs.webkit.org/show_bug.cgi?id=164761>). Yusuke went to replace JSC’s use of SetForScope with TemporaryChange. When I reviewed his patch, I suggested to him to rename the class to SetForScope because it was my personal preference of the two names. However, I should have first discussed this change with other WebKit developers (so I’m doing that now, retroactively).

If there is a strong preference to use the name TemporaryChange instead of SetForScope, I’ll rename the class back to its original name.

My personal preference is still for the name SetForScope, but my feelings are not strongly tied to one name or the other.

- Saam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-dev/attachments/20161222/e69e4fa5/attachment.html>

More information about the webkit-dev mailing list