[webkit-dev] Build slave for JSCOnly Linux MIPS

Michael Catanzaro mcatanzaro at igalia.com
Mon Apr 18 14:08:11 PDT 2016

On Mon, 2016-04-18 at 22:36 +0300, Konstantin Tokarev wrote:
> Are there any objections for lowering GCC requirement from 4.9.0 to
> 4.8.4 (only for JavaScriptCore without B3)? I'm going to fix arising
> compilation errors myself.

I've been kinda hoping to do this regardless, since you started
contributing GCC 4.8 buildfixes. GCC 4.8 is still being used by a
prominent distributor that's recently started releasing occasional
WebKit updates. I worked on downstream patches to remove the GCC 4.9
requirement so that their users can get WebKit updates. Since
increasing our GCC requirement past the GCC version included in a
distribution just guarantees users will never receive WebKit security
updates, we need to recognize that we moved too quickly in increasing
our requirement to GCC 4.9. (At the time I thought this was OK, but I
was wrong.) We'll need to be more careful in the future when bumping
our GCC requirement, lest we leave a large segment of users stuck on
ancient versions of WebKit.

It's unfortunate as of course we want to be able to use new language
features, but we need to balance this with the desire to ensure our
updates reach users.


More information about the webkit-dev mailing list