[webkit-dev] Clarifying 3D feature defines
simon.fraser at apple.com
Thu Apr 23 16:48:45 PDT 2015
On Apr 23, 2015, at 4:39 PM, Martin Robinson <mrobinson at webkit.org> wrote:
> In the process of cleaning up and dusting off the GTK+ cmake build
> system, we have rediscovered the pair of somewhat confusing feature
> defines WTF_USE_3D_GRAPHICS and ENABLE_3D_RENDERING. From a brief
> audit, it appears that WTF_USE_3D_GRAPHICS is a generic flag for any
> kind of 3D rendering at all (including WebGL), while
> ENABLE_3D_RENDERING refers specifically to perspective
> Would it be worthwhile to clarify these flags slightly? My proposal is
> to rename ENABLE_3D_RENDERING to either ENABLE_3D_TRANSFORMS or
> ENABLE_PERSPECTIVE_TRANSFORMS, though I support any names that reduce
> the possible confusion between these flags.
USE(3D_GRAPHICS) appears to surround WebGL code in general. I don’t see any non-WebGL bits in a quick search.
ENABLE(3D_RENDERING) means “turn on the ability to support and render 3D CSS transforms)”. I would be OK with ENABLE_3D_TRANSFORMS, which is more accurate than ENABLE_PERSPECTIVE_TRANSFORMS.
More information about the webkit-dev