[webkit-dev] Rename PLATFORM(MAC) to PLATFORM(COCOA)?
mitz at apple.com
Sat Jan 11 15:05:05 PST 2014
On Jan 11, 2014, at 2:47 PM, Darin Adler <darin at apple.com> wrote:
> Hi folks.
> There is a lot of WebKit code that needs to be on for “the Mac and iOS ports”. Some of it is guarded be conditionals with a higher level concept. But most of it, now this is guarded by PLATFORM(MAC). I think that’s really confusing and we need to rename PLATFORM(MAC) to something else. Perhaps PLATFORM(COCOA)? Or maybe it’s SOMETHING_ELSE(COCOA)?
> Then we can use PLATFORM(MAC) for “the Mac port” rather than PLATFORM(MAC) && !PLATFORM(IOS).
> Later we can start renaming file names as well, but for now I just want to fix the conditionals to be more readable. And of course, it’s even better in cases where we can move away from platform conditionals to more logical conditionals such as USE(CF) or USE(APPKIT).
> So, is PLATFORM(COCOA) an acceptable new name for what is currently named PLATFORM(MAC)?
> If not, what’s a better choice?
> Lets do this soon. It’s hard for me to remember that in WebKit, PLATFORM(MAC) means “the Mac and iOS ports”.
> — Darin
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
More information about the webkit-dev