[webkit-dev] Problems building JavaScriptCore/WebKit for Windows desktop

Brent Fulgham bfulgham at apple.com
Wed Apr 9 15:31:09 PDT 2014

Hi Eric,

I’m sorry you encountered problems building WebKit. I’ve interleaved some responses below.

On Apr 1, 2014, at 4:34 AM, Eric Wing <ewmailing at gmail.com> wrote:

> I am trying to build JavaScriptCore for Windows desktop. (Ultimately,
> I just want a x86_64 .lib and .dll I can link against for Win 7 and 8.
> I would be happy not building it and just downloading the pre-build
> binaries somewhere if that's an option.)

You might want to take a look at dim3 <http://en.wikipedia.org/wiki/Dim3>. Brian Barnes has been generating JSC builds from time-to-time for use in his game engine.

> - The cygwin-downloader instructions about installing from the Local
> Directory doesn't seem to work. When it is time to hit 'Next' in the
> select the packages screen, it seems that the packages are not
> detected. This results in nothing getting installed. My attempts to
> force it to detect and install have failed.

As far as I know, this works. Please file a bug at <http://bugs.webkit.org> with log output if you are seeing problems.

> 	- The python version it picks by default is 2.7.x and Webkit
> complains it needs 2.6.x so I have to force a downgrade.

Yes. This is extremely annoying, but Cygwin has not released a 32-bit Python that works.

> 	- The curl or ssl package has some kind of bug and either requires a
> downgrade of one of the packages or a change to the
> update-webkit-dependency script to use tlsv1 instead of sslv3

This is a known issue with cURL 7.34.0, which I documented separately. This has been fixed by the cURL project, but I have not seen a Cygwin update with the fixes.

> 	- There is a missing instruction that C:\cygwin\bin must be added to
> the Windows %PATH%, otherwise a bunch of "/usr/bin/which bash"
> commands fail (because it can't find bash)

I’m surprised by this. The CMD files that emit this error message should be setup to ignore it. If it cannot find bash, it updates the PATH with the Cygwin path. So, I suspect that those messages are simply warnings to you, not actual errors that block the build. If they are terminating your build, please file a bug and attach logging output.

> 	- I get a warning about having svn 1.8.8 when 1.7.10 is the supported one

Yes. I discussed this issue separately.

> - The php instructions to install php don't work. I think a link is broken.

Can you file a bug with the error you are seeing?

> - Running update-webkit causes me problems with Git (it just hangs) so
> I went to the SVN source ball.

I think I ran into this error myself several months ago when I accidentally put a git checkout somewhere inside my svn repository. If you continue to see a problem with this, please file a bug.

> - update-webkit reports after the SVN 1.8.8 warning with 2 instances
> of "Error (2): The system cannot find the file specified." I don't
> know what it's complaining about. It goes on to tell me I don't have
> the Mozilla Math fonts. (I think those links may be stale.) But
> finally it says "Installed tools are correct for the Webkit build”

The ‘cannot find the file specified’ are checks for installed MathML fonts. You need these for testing (and to get good MathML rendering in WinLauncher), but they are not needed to build. You can ignore these messages.

> Using the latest version (Monday) with Visual Studio 2013, I think
> there are some new bugs in the code base. The build now expects Core
> Foundation to be available on Windows to build WTF. This was not the
> case before and I think this is a new bug. This propagates down to
> SchedulePair.h which doesn't seem to have any non-Core Foundation
> path. (I expect this will be a problem speaking from my Android work.)

Both the Apple Windows and WinCairo ports use (a form of) CoreFoundation. WinCairo uses the ‘OpenCFLite” version of CoreFoundation. You need this support library to build WebKit and JSC, as documented on our website.

> One of the prior versions was failing on ruby related stuff or could
> not find files. I'm not fuzzy on the details because I've tried way
> too many things.

I’m sorry you encountered problems, but its very difficult to make suggestions without some details. Could you please file bugs about what you’ve encountered?

Good luck!


More information about the webkit-dev mailing list