[webkit-dev] Problems building JavaScriptCore/WebKit for Windows desktop

Eric Wing ewmailing at gmail.com
Tue Apr 1 04:34:56 PDT 2014

I am trying to build JavaScriptCore for Windows desktop. (Ultimately,
I just want a x86_64 .lib and .dll I can link against for Win 7 and 8.
I would be happy not building it and just downloading the pre-build
binaries somewhere if that's an option.)

I've followed the instructions on the web page about building Webkit
and even looked to outside documentation, but I'm having tons of
problems. I've done multiple fresh installs of Windows 7 and 8.1 with
different versions of Visual Studio in VMs, but I'm not having any

Among my various problems:
- The cygwin-downloader instructions about installing from the Local
Directory doesn't seem to work. When it is time to hit 'Next' in the
select the packages screen, it seems that the packages are not
detected. This results in nothing getting installed. My attempts to
force it to detect and install have failed.
	- To workaround, I did the install the "default" way through the
internet. I manually went down the list selecting packages based on
the ones cygwin-downloader I see saved on my hard disk.
	- The python version it picks by default is 2.7.x and Webkit
complains it needs 2.6.x so I have to force a downgrade.
	- The curl or ssl package has some kind of bug and either requires a
downgrade of one of the packages or a change to the
update-webkit-dependency script to use tlsv1 instead of sslv3
	- There is a missing instruction that C:\cygwin\bin must be added to
the Windows %PATH%, otherwise a bunch of "/usr/bin/which bash"
commands fail (because it can't find bash)
	- I get a warning about having svn 1.8.8 when 1.7.10 is the supported one
- The php instructions to install php don't work. I think a link is broken.
- Running update-webkit causes me problems with Git (it just hangs) so
I went to the SVN source ball.

- update-webkit reports after the SVN 1.8.8 warning with 2 instances
of "Error (2): The system cannot find the file specified." I don't
know what it's complaining about. It goes on to tell me I don't have
the Mozilla Math fonts. (I think those links may be stale.) But
finally it says "Installed tools are correct for the Webkit build"

- I tried building using the build-jsc and build-webkit scripts and
also by opening the JavaScriptCore.sln directly in Visual Studio.

I grabbed WebKit in 3 different some what random states. One was from
around July. One was maybe 4 months ago. And one was from Monday.

Each one seemed to have a different problem and also looked for a
different Visual Studio version. This is what prompted me to install
all the different Visual Studio versions, with still no luck.

Using the latest version (Monday) with Visual Studio 2013, I think
there are some new bugs in the code base. The build now expects Core
Foundation to be available on Windows to build WTF. This was not the
case before and I think this is a new bug. This propagates down to
SchedulePair.h which doesn't seem to have any non-Core Foundation
path. (I expect this will be a problem speaking from my Android work.)

One of the prior versions was failing on ruby related stuff or could
not find files. I'm not fuzzy on the details because I've tried way
too many things.

I would appreciate any advice/help in getting this built or just
getting a set of release binaries I can take and run. I don't need
bleeding edge stuff. I just want something that works.

Beginning iPhone Games Development

More information about the webkit-dev mailing list