[webkit-dev] Getting started with making Qt WebKit patches

Sze Howe Koh szehowe.koh at gmail.com
Mon Mar 25 08:00:35 PDT 2013


I'm trying to submit a patch for Qt WebKit. I've applied the patch to
my local copy of qtwebkit.git, but am having trouble using
webkit-patch. What am I missing?

I'm running Windows 8 x64, Git version 1.8.0.msysgit.0, and
ActivePython 2.7.2 x64. From Git Bash, I called
`Tools/Scripts/webkit-patch prepare --cc=hausmann at webkit.org'

I got the error message below, but am not told what file the script is
unable to find. I tried it with my changes uncommitted and committed,
but got the same result.

Traceback (most recent call last):
  File "Tools/Scripts/webkit-patch", line 84, in <module>
  File "Tools/Scripts/webkit-patch", line 79, in main
  File "c:\Qt\git\5.x.y\qtwebkit\Tools\Scripts\webkitpy\tool\multicommandtool.py",
line 304, in main
  File "c:\Qt\git\5.x.y\qtwebkit\Tools\Scripts\webkitpy\tool\main.py",
line 94, in handle_global_options
  File "c:\Qt\git\5.x.y\qtwebkit\Tools\Scripts\webkitpy\common\host.py",
line 132, in initialize_scm
    self._scm = detector.default_scm(patch_directories)
  File "c:\Qt\git\5.x.y\qtwebkit\Tools\Scripts\webkitpy\common\checkout\scm\detection.py",
line 55, in default_scm
    scm_system = self.detect_scm_system(cwd, patch_directories)
  File "c:\Qt\git\5.x.y\qtwebkit\Tools\Scripts\webkitpy\common\checkout\scm\detection.py",
line 71, in detect_scm_system
    if SVN.in_working_directory(absolute_path, executive=self._executive):
  File "c:\Qt\git\5.x.y\qtwebkit\Tools\Scripts\webkitpy\common\checkout\scm\svn.py",
line 93, in in_working_directory
    exit_code = executive.run_command(svn_info_args, cwd=path,
  File "c:\Qt\git\5.x.y\qtwebkit\Tools\Scripts\webkitpy\common\system\executive.py",
line 405, in run_command
  File "c:\Qt\git\5.x.y\qtwebkit\Tools\Scripts\webkitpy\common\system\executive.py",
line 461, in popen
    return subprocess.Popen(*args, **kwargs)
  File "c:\Python27\lib\subprocess.py", line 679, in __init__
    errread, errwrite)
  File "c:\Python27\lib\subprocess.py", line 893, in _execute_child
WindowsError: [Error 2] The system cannot find the file specified


Running Tools/Scripts/prepare-ChangeLog worked ok, but I was under the
impression that webkit-patch is preferred as it automates a lot more
aspects of the workflow (is that correct?)

Thanks in advance for your guidance.


More information about the webkit-dev mailing list