[webkit-dev] change MediaControlToggleClosedCaptionsButtonElement type to checkbox

Silvia Pfeiffer silviapf at chromium.org
Sun Jun 23 00:23:36 PDT 2013

I think this is a good idea. When I coded the video controls initially, I
tried to stick as close as possible to what they were in Safari/WebKit so
that we could avoid duplication in CSS etc, but that's not relevant any
longer. Buttons are semantically the right element to use.


On Tue, Jun 4, 2013 at 11:52 AM, Danilo Cesar <danilo.eu at gmail.com> wrote:

> Is there any special reason why
> MediaControlToggleClosedCaptionsButtonElement is created with
> type==button and not type==checkbox?
> (Source/WebCore/html/shadow/MediaControlElements.cpp:694)
> I say that because its implementation uses setChecked(true/false)
> (MediaControlElements.cpp:716 and 704), which doesn't reflect on the
> behavior of the :checked selector for
> video::-webkit-media-controls-toggle-closed-captions-button defined on
> Source/WebCore/css/mediaControls[PORT].css, since that element is a
> button.
> For almost all the ports, the behavior of that component looks more
> like a checkbox (turning captions on/off).
> My question is: is it Ok to change the type of that object to
> "checkbox"? If we also change the defaultEventHandle (line 707) to
> capture the changeEvent instead of clickEvent, the behavior for all
> ports (including mac) shouldn't change. I think that all ports that
> uses it as a toggle will benefit from that, and it won't hurt apple's
> implementation.
> Proposal/draft here: https://bugs.webkit.org/show_bug.cgi?id=117177
> --
> Danilo Cesar Lemes de Paula
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20130623/0d51a026/attachment.html>

More information about the webkit-dev mailing list