[webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo
Emil A Eklund
eae at chromium.org
Tue Jun 18 19:03:45 PDT 2013
On Tue, Jun 18, 2013 at 6:38 PM, Darin Adler <darin at apple.com> wrote:
> What do you think of these names instead?
> StyleResolver* optionalStyleResolver();
> StyleResolver& requiredStyleResolver();
+1, much clearer and the pointer vs reference makes it even more so.
Perhaps enough so that the required prefix could be dropped:
More information about the webkit-dev