[webkit-dev] Int/FloatPoint and Int/FloatSize

Ryosuke Niwa rniwa at webkit.org
Wed Jan 9 16:49:37 PST 2013

On Wed, Jan 9, 2013 at 3:47 PM, Steve Block <steveblock at chromium.org> wrote:

> > Also, the word "position" is used to represent a tree-position in DOM in
> > WebKit so please don't use that to represent a point in a screen or a
> layout
> > coordinate system.
> OK, perhaps we should use Vector2d, as is used by the Chromium port

My reference, if we’re doing this rename after addressing concerns
expressed by Simon and others, is TwoDimensionalVector, R2Vector, or
VectorInR2 because it’s a vector in a two-dimensional vector space, not a
"2d" of type vector.

- R. Niwa
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20130109/f31e1826/attachment.html>

More information about the webkit-dev mailing list