[webkit-dev] Int/FloatPoint and Int/FloatSize

Ryosuke Niwa rniwa at webkit.org
Fri Jan 4 00:18:47 PST 2013

On Thu, Jan 3, 2013 at 10:32 PM, Steve Block <steveblock at chromium.org>wrote:

> > I find point - point = size quite useful in general, and it seems to
> make logical sense.
> I agree that it makes logical sense, but I think that 'point - point =
> point' also makes sense, and is perhaps more frequently the right
> choice.
> > What would you call this type, avoiding confusion with Vector<>?
> I guess 'Offset' is an obvious candidate, but that is probably already
> too overloaded. Perhaps RelativePosition or RelativePoint?

I don't think "Relative" adds any value here.

Also, the word "position" is used to represent a tree-position in DOM in
WebKit so please don't use that to represent a point in a screen or a
layout coordinate system.

I don't like "offset" either because it's such an overloaded word. e.g.
"offset" is often used to mean a child node index in DOM.

- R. Niwa
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20130104/f059047b/attachment.html>

More information about the webkit-dev mailing list