[webkit-dev] Testing feature suggestion: animation/interaction pixel-results "on the fly"

Benjamin Poulain benjamin at webkit.org
Wed Feb 13 23:07:24 PST 2013


On Wed, Feb 13, 2013 at 9:38 PM, Dongsung Huang <luxtella at company100.net>wrote:

> I like this idea. I cannot find any harm if we have this functionality.
>

Those changes are not harmless. There are people monitoring tests results
full time in order to keep WebKit in good shape. No other part of WebKit
require continuous attention.


> Case 1: CSS Filters & Shaders
> I wanted this test functionality when I commented
> http://webkit.org/b/97859#c19
> If I want to make gaussian blur test, I prefer using 'getPixel' test as
> follows,
>

Why wasn't a ref-test a better solution in this particular case?

Case 2: Fixed Position Element
> [...]
> function repeatedlyCalledDuringScrolling() {
>     ASSERT(getPixel(15, 9) == white);
>     ASSERT(getPixel(15, 10) == green);
>     ASSERT(getPixel(9, 15) == white);
>     ASSERT(getPixel(10, 15) == green);
>     ....
> }
>

I think this shows what I said about correctness and readability:
-Asserting the correctness of the test and the result becomes close to
impossible for the reader. One has to review the full code to have a chance
of understanding an error.
-You cannot cover non trivial cases (images, text, form elements, etc).
-And it is inefficient. You have to render each frame on the UIProcess,
move it to the WebProcess, and box it for JavaScript to process (with pixel
format conversions depending on your graphics system)

Of the ideas raised, I think this is one of my least favorite for testing
fixed positioning.

Benjamin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20130213/0f15b4fd/attachment.html>


More information about the webkit-dev mailing list