[webkit-dev] ChangeLog format

Joseph Pecoraro pecoraro at apple.com
Thu Aug 22 12:34:00 PDT 2013


On Aug 22, 2013, at 12:46 AM, Carlos Garcia Campos <carlosgc at webkit.org> wrote:

> El jue, 22-08-2013 a las 00:41 -0700, Mark Rowe escribió:
>> On 2013-08-21, at 11:11 PM, Carlos Garcia Campos <carlosgc at webkit.org> wrote:
>> 
>>> I see, I thought ChangeLog parser was used everywhere. So, I guess the
>>> solution would be to find a format most people like and adapt all
>>> scripts to it. I personally think it's not worth it, though. The oneline
>>> git log format is ok with the old commit message format IMO. If the only
>>> problem is that the bug number is not in the first line we can probably
>>> add it without adding the URL in angle brackets, something like:
>>> 
>>> Bug 119872 - REGRESSION: Crash under JITCompiler::link while loading Gmail
>>> https://bugs.webkit.org/show_bug.cgi?id=119872
>> 
>> What benefit does duplicating the bug number in the first line provide? It’s just yet another thing to have to add when writing the ChangeLog entry.
> 
> The benefit is that you see the bug number when using git log oneline
> format, I'm guessing that seeing the bug number in the first line was
> the motivation of the new ChangeLog format.


I prefer the new format. However, the new format doesn't really gain us much, so it sounds like it is not worth the effort to change.

As for duplicating the bug number, I don't think that matters. `git log --oneline` shows a short SHA the "title line" which is everything in the commit message until the first empty line. So duplicating the bug number in the first line doesn't really help, since both of these lines already show up.

Old format:

shell> git log --oneline `git svn find-rev r153963` -10
503293b Move additionalIdentifiers into DFGCommonData as only the optimising JITs use them https://bugs.webkit.org/show_bug.cgi?id=119705
2dbc921 Stop making unnecessary copy of CodeBlock Identifier Vector https://bugs.webkit.org/show_bug.cgi?id=119702
c0c68df [cairo] memory corruption with putImageData and accelerated canvas. https://bugs.webkit.org/show_bug.cgi?id=118621
0502819 Layout Test fast/overflow/scrollbar-click-retains-focus.html is failing on Apple Mac WK1 and GTK. https://bugs.webkit.org/show_bug.cgi?id=104104
c19a87b Use const AtomicStringImpl* in DocumentOrderedMap https://bugs.webkit.org/show_bug.cgi?id=119700
02c59d8 The LayoutMilestones didLayout callback should only fire for the main frame https://bugs.webkit.org/show_bug.cgi?id=119457
2cb3317 Remove didNewFirstVisuallyNonEmptyLayout from WebKit2 https://bugs.webkit.org/show_bug.cgi?id=119658
6cb5165 Define DOM_KEY_LOCATION_* constants on KeyboardEvent https://bugs.webkit.org/show_bug.cgi?id=119341
597845d Remove glu's libtest rule from checker.py https://bugs.webkit.org/show_bug.cgi?id=119674
35852cd Multiple CSP tests complain about undefined strings in echo-object-data.pl and echo-script-src.pl https://bugs.webkit.org/show_bug.cgi?id=119692

New format:

shell> git log --oneline `git svn find-rev r154274` -10
c3bd590 <https://webkit.org/b/119882> Speed up moving cursor/selection up or down past non-rendered elements.
6c326ac <https://webkit.org/b/119933> [Qt] Fix tst_QObjectBridge::connectAndDisconnect() fail
381c093 <https://webkit.org/b/120000> Chrome::client() should return a reference.
f183c4b <https://webkit.org/b/120004> Rename StyleElement to InlineStyleSheetOwner and stop inheriting from it
0d74bc3 [Qt] QtWebKit (using the Arora browser) displays the border radii (radius) of a button very ugly https://bugs.webkit.org/show_bug.cgi?id=28113
e5a4a31 <https://webkit.org/b/119998> [Qt] Build fix (broken since r154257).
d3ac166 <https://webkit.org/b/120001> Clean up StyleElement
5c403bd <https://webkit.org/b/119990> Add toSVGStopElement(Node* node) to clean-up a static_cast<SVGStopElement*>
508cc36 <https://webkit.org/b/119996> Introduce toSVGAnimateElement(), and use it
db5024b <https://webkit.org/b/119997> Page::progress() should return a reference.

- Joe
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20130822/1c30712a/attachment.html>


More information about the webkit-dev mailing list