[webkit-dev] Reorganization of animation starting

Balazs Kelemen kbalazs at webkit.org
Wed Apr 17 17:10:36 PDT 2013

On 04/17/2013 10:27 AM, Nándor Huszka wrote:
> Hi All,
> There is an optimization problem related to animations.
> If we have one out of the visible viewport, it is still animated.
> (Try to scroll down on http://philbit.com/animatedgiftest.html)
> In this case it would be good to stop, then continue animations when it is
> required.
> Now a BitmapImage's animation is started (continued) when it is drawed,
> and animation does not stop until it is destroyed.
> If animation starting would be handled separately from drawing, we could
> start and stop it when it is needed.
> Under https://bugs.webkit.org/show_bug.cgi?id=112327 there is a
> preliminary patch for it.
> The main idea in a nutshell: remember every animation in FrameView
> (instead of painting it),then only resume ones are on the visible
> viewport. For more details please check the bug.
> Reorganizing animation starting raises an important question.
> I plan to modify every ports' code where startAnimation is called, because
> after this patch it would be FrameView's role.
> If we would rename startAnimation to continueAnimation it could help with
> finding code points where startAnimation are called and should be removed
> by investigating EWS build logs.
> On the one hand it would be a more expressive name for that the method does.
> What do you think about the conception and about the method renaming?

IMHO grep is a better tool to find call sites than ews, you should not 
rename just for that. If the change in behaviour implies the renaming 
than still it's probably better to do it in a follow-up patch.

> br,
> Nándor
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev

More information about the webkit-dev mailing list