[webkit-dev] New Feature: Canvas Path object
mjs at apple.com
Mon Sep 24 13:02:31 PDT 2012
I'm not hung up on the name. But if we are worried about name collision, we could do data gathering on use of Path or other candidate names instead of just guessing.
On Sep 24, 2012, at 12:22 PM, Dirk Schulze <dschulze at adobe.com> wrote:
> On Sep 24, 2012, at 12:03 PM, "Rik Cabanier" <cabanier at gmail.com> wrote:
>> On Mon, Sep 24, 2012 at 10:27 AM, Darin Adler <darin at apple.com> wrote:
>> On Sep 22, 2012, at 9:21 PM, Elliott Sprehn <esprehn at chromium.org> wrote:
>> > On Fri, Sep 21, 2012 at 6:34 AM, Dirk Schulze <dschulze at adobe.com> wrote:
>> >> I would like to ask if there are objections to implement the canvas Path object.
>> > Do we have metrics on how often people already have things named Path? All other canvas objects have a prefix like CanvasGradient and CanvasPattern, this thing seems inconsistent and more likely to break existing pages.
>> Dirk, given the fact that you quite logically referred to this as “the canvas Path object” when mentioning it to us, and the fact that both CanvasGradient and CanvasPattern objects exist, CanvasPath sure does seem like a nice name for this. Someone should make that suggestion on the WebApps mailing list!
> I am interested in the feature, not the name. I am fine with naming it CanvasPath. Remember that Path is not limited to Canvas, other then for instance SVGPathElement. I just want to avoid that people come to the impression that this can just be used for Canvas.
>> A difference though is that the path object doesn't have to be associated with a canvas. It is/will be useful with other features such as SVG as well.
>> I feel uneasy with the generic name too; maybe a DOM/HTML/JS prefix is better.
> DOM and HTML will lead to the same wrong conclusions IMO. And JS seems unusual as prefix.
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev