[webkit-dev] Adding reverse flag to Widget::SetFocus?
fsamuel at chromium.org
Mon Sep 10 12:32:45 PDT 2012
I'm working on a plugin that needs to deal with focus. I'd like this plugin
to look an feel just like any other DOM element including the way it deals
with focus. The problem that I have is Widgets know about focus but not
focus direction (forward/reverse). My plugin has several logical
subelements. The initial subelement to select is based on the direction
taken to arrive to the plugin by keyboard (Tab v.s. Shift-Tab).
I'd like to add a new parameter with a flag or enum three states perhaps:
Foward Reverse, Neither to Widget::SetFocus.
This is going to require many one-line changes throughout a number of files
Before I embark on such a change, I'd like to get some feedback at this
point. Is this a reasonable thing to add? Does anyone oppose this change?
Is there a cleaner way to add this support?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev