[webkit-dev] Unprefixing requestAnimationFrame

James Simonsen simonjam at chromium.org
Thu Oct 11 17:29:08 PDT 2012

I've posted a patch to remove the "webkit" prefix from
requestAnimationFrame. [1] The question is whether or not to continue to
support the prefixed version. I propose dropping it for the following

1. We're changing the callback semantics to match the spec. [2]

2. IE10 is shipping with this unprefixed. [3]

3. Toolkits already use the unprefixed version. [4]

4. The advice on the internet recommends everyone use the polyfill
technique. [5]

I'm curious what everyone else thinks.


[1] https://bugs.webkit.org/show_bug.cgi?id=99116
[2] https://bugs.webkit.org/show_bug.cgi?id=66683
[3] http://caniuse.com/#feat=requestanimationframe
[4] https://gist.github.com/1579671
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20121011/659c17eb/attachment.html>

More information about the webkit-dev mailing list