[webkit-dev] Is there a rule to use UNUSED_PARAM ?
mikelawther at google.com
Mon Oct 1 18:17:15 PDT 2012
On 2 October 2012 10:51, Ryosuke Niwa <rniwa at webkit.org> wrote:
> How about ASSERT_OR_UNUSED or ASSERT_USING_UNUSED?
> On Mon, Oct 1, 2012 at 5:23 PM, Darin Adler <darin at apple.com> wrote:
>> On Oct 1, 2012, at 5:21 PM, Mike Lawther <mikelawther at google.com> wrote:
>> > my first reading of that name had me thinking it meant 'ASSERT that
>> this variable is unused' in the vein of macros I've seen in other places
>> like ASSERT_TRUE, ASSERT_NOT_NULL etc.
>> Yes, even though I named the macro I have had the same thought often. I
>> love the macro, but a better name, even if a bit longer, would be welcome.
>> If we can think of one we can fix this with a quick global replace.
>> -- Darin
>> webkit-dev mailing list
>> webkit-dev at lists.webkit.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev