[webkit-dev] …Inlines.h vs …InlineMethods.h
mark.lam at apple.com
Fri Nov 2 17:48:55 PDT 2012
Naming-wise, the existing JSC code has a few inline headers named …Inlines.h and more named …InlinedMethods.h. On the WebCore side, the few that exists there are named …InlineMethods.h. I have a preference for the …Inlines.h convention because it is shorter and concisely communicates the intent. I plan to rename all these inline headers to be …Inlines.h for consistency. Does anyone object to my renaming the inline headers?
Also, a lot of the existing inlined methods are 1 liners. I plan to leave these in the original header file. Here's the convention I'm going to adopt:
1. If the inline method is a 1 liner, then leave it in the original header file.
2. If it takes more than 1 line, then move it into a corresponding inline header file.
I will only be breaking out the inline methods (per the above convention) in the JSC sources. Apart from renaming the few WebCore inline headers, I won't be looking into WebCore's placement of inline methods for now.
If anyone has an opinion on this, please let me know asap. Thanks.
More information about the webkit-dev